1988 2.9l flooding - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 08-08-2013
Thread Starter

I am: mark tyner
Join Date: May 2013
Location: plano, texas
Vehicle: Ford Ranger
Posts: 2
Total Props: 0
1988 2.9l flooding

I pulled the engine to replace the oil pump an re-seal it. It ran great before it was re-sealed. The plugs, wires, cap, and rotor have been replaced. I replaced the ignition module and the idle position sensor. I did have it running enough to have it diagnosed, Can't rember what the code was but it was getting to much raw gas at the o2 sensor. I pulled the plugs and if seems to be getting to much gas. The fuel pressure at the rail is 40 p.s.i. Now it will not start. Any ideas?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flooding when starting k.blakeley 4.0L OHV & SOHC V6 Tech 4 02-22-2009 03:14 PM
Ranger not starting, only clicking. Possible flooding. HELP!!!!!! Prerunner-Ranger 2.9L & 3.0L V6 Tech 79 01-09-2009 12:39 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:47 AM.