2.9L EFI Electronic Advance issue - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 02-01-2013
Thread Starter

I am: Steven Becker
Join Date: Feb 2013
Location: Fritz Creek
Vehicle: 1986 Ford Ranger 2.9L
Posts: 1
Total Props: 0
Icon5 2.9L EFI Electronic Advance issue

Have a 1986 2.9L fuel injected that idles alright but when you put it in first and actually take her through the gears she misses throughout the entire range and all RPMs (so bad it jerks the truck violently). I have changed plugs, checked distributor, plug wires, and timing, changed fuel filter and checked fuel pressure. Big clue came when i removed the chip that disables the electronic advance (like you're supposed to do when you time the engine) and she drove smooth as can be with no missing (but lacked obvious power due to E-Advance being disabled). What would this likely be...the PCM (EEC-IV), ICM (TFI-IV), or some random sensor.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: C4/BW1350 Advance Adapter Explorer Engine & Drivetrain 2 11-24-2010 02:02 PM
Thanks in advance! dangerranger10 Member Introductions 2 04-16-2010 10:59 AM
Crank position sensor advance? Oh5Edge 2.9L & 3.0L V6 Tech 0 01-10-2008 03:21 PM
Advance cam? BOB 2.9L & 3.0L V6 Tech 30 03-17-2006 09:56 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:17 AM.