2000 ranger 3.0 loosing fuel pressure when hot under load - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 09-13-2016
Thread Starter

I am: Owen
Join Date: Sep 2016
Location: Chesterfield mass
Vehicle: 2000 Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 2
Total Props: 0
2000 ranger 3.0 loosing fuel pressure when hot under load

So my 2000 ranger 3.0 flex fuel will start and run fine for about 15 minutes, then starts loosing fuel pressure only when under a load. You can push the clutch in and give it gas and the fuel pressure won't move. I put a fuel pressure gauge on it while diving and its stays between 50-60psi until it starts acting up, then will slowly drop down to 20psi and starts to backfire. At that point if you shutdown and restart fuel pressure will go back to 50-60, until about 15 minutes of driving and it starts dropping again. I've replaced crank sensor and camshaft position sensor and also newer fuel pump.I am stumped. Any help greatly appreciated
Reply With Quote
+ 0 -
Old 09-14-2016
I am: Jeff Martin
Join Date: Jul 2016
Location: BC Canada
Vehicle: 1999 Mazda B3000
Drive Type: 4x2
Engine: 3.0
Posts: 322
Total Props: 4
Did you replace the fuel filter ?
My 99, has a filter on it, so I'm going to assume that yours does too.
Reply With Quote
+ 0 -
Old 2 Weeks Ago
I am: Dustin Cook
Join Date: Oct 2016
Location: rochester new york
Vehicle: 2001 Ford ranger
Drive Type: 2x4
Engine: 3.0
Posts: 1
Total Props: 0
sounds like the problem i had about a month ago...go and see if you got any codes first if you get too lean on banks 1&2 most likely it's your fuel filter like i did

hot tip....wear eye protection along with something to cover your mouth gas in your face isn't fun and doesn't taste as good as it feels
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Ranger STX 2wd clunk/clack under load Satan Jamez General Technical & Electrical 1 10-04-2013 05:25 PM
94 ranger 4 cly cuts out under load fyi SOHC - 2.3L & 2.5L Lima Engines 10 01-13-2012 12:29 PM
Help with 1994 4.0L Ranger misfiring & hesitating under load? danmm7 4.0L OHV & SOHC V6 Tech 5 11-06-2011 02:18 PM
site taking forever to load/partial load morris Ranger-Forums Office 59 09-05-2011 11:59 PM
04 ranger, spitting and sputtering under load polarrey 2.9L & 3.0L V6 Tech 10 06-03-2011 10:34 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:11 AM.