3.0 loosing power plugs white - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 02-05-2013
Thread Starter

I am: chuck pagach
Join Date: Mar 2011
Location: escondido CA.
Vehicle: 2003 xlt
Posts: 1
Total Props: 0
3.0 loosing power plugs white

I have a 2003 3.0 its run rough for a long time thinking its a valve seat. But lately I have lost a lot of power, I pulled the plugs and they look lean they are white and that's on all cylinders. I did the propane test thinking I have a vacuum leak but the engine idle didn't change. Any other ideas on what it could be thanks.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Ranger running rough, low power, loosing anti-freeze drumz SOHC - 2.3L & 2.5L Lima Engines 2 05-29-2012 01:22 PM
Need some advice. Loosing antifreeze Rascal General Ford Ranger Discussion 33 11-16-2011 07:23 PM
Loosing Engine Coolant ChaosFromAbove 2.9L & 3.0L V6 Tech 25 03-10-2009 06:56 PM
Loosing gas mileage with Intake? vansnxtweek 4.0L OHV & SOHC V6 Tech 29 02-05-2006 11:07 PM
loosing my t-bar crank.... INT3RC3PTOR Suspension Tech 10 01-21-2006 09:55 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:06 AM.