4x4 and dome light? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 10-08-2011
gcextreme's Avatar
Thread Starter

I am: Glenn Cox
Join Date: Sep 2011
Location: Villard, Minnesota
Vehicle: 1998.99 Ford Ranger
Posts: 126
Total Props: 0
4x4 and dome light?

Ok so I have a 99 ranger xlt 3.0 4x4 automatic ext cab. Bought the truck with 118k on it in 2004, and in 2006 with 128k had to replace the engine, long story. Last year at 172k I lost reverse, had to rebuild the transmission.

Anyway after the new motor was put in, I started having 4x4 issues, was told it was the vac lines in the hubs. I put in those AVM rugged ridge manual lockouts. They seem to work fine. But I have the following issues.
The 4wd High and Low lights blink randomly. I mean totally random. I have had the truck in 2 wd all summer, they still blink randomly.
And when they blink, the dome light will not come on, are these connected? Is it a bad ground or is it the gem module. I have checked the fuses, replace most of them.
Back to the random blinking. Sometimes it seems they start to blink, but then get cut short. It will blink like one or two times and then start a Thurs blink but cut out, not stay on for the full length of time. Hard to explain. Lets say they blink and each blink it stays on for 3 seconds. Well every now and then, a blink is cut short to like 1 second.

They always blink when I start the truck and stat driving and the dome light won't come on. They will blink for a few miles and then stop, and then I cam get the dome light to come on. Everything will be fine for several miles and minutes, then it happens again.

Sometimes I can go several days with it not happening and its all fine, other times it happens all the time.

I have been told the following:
Because I switched to manual hubs, the computer is having issues or the sensor is having issues.

Its a faulty gem module or computer/board.

Its a faulty shift motor or bad connection at the shift motor.

Its a bad ground or short somewhere.

Any ideas or suggestions??
I live in snowy Minnesota, and need 4wd for winter. Last year I would put it in 4wd and it would work, but after a few minutes the lights would blink and id lose 4wd, the lights would just stay off for a bit, and then after a time the 4wd high light would come back on and I would have 4wd again. It sucks to have it cut out and not come on when u need it.

Please advise
Reply With Quote
+ 0 -
Old 10-08-2011
99offroadrngr's Avatar
iTrader: (37)
I am: JD M
Join Date: Jul 2007
Location: Massachusetts
Vehicle: 2004 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 11,719
Total Props: 39
Its definitely not the first thing you've been told that switching to manual hubs messes with it, thats total BS. Another member had something similar with his dome light not coming on recently and he thinks it might have been the GEM but I haven't really followed the outcome of it.

EDIT: it was a pinched wire on his overhead console.

Last edited by 99offroadrngr; 10-08-2011 at 10:06 AM.
Reply With Quote
+ 0 -
Old 10-08-2011
gcextreme's Avatar
Thread Starter

I am: Glenn Cox
Join Date: Sep 2011
Location: Villard, Minnesota
Vehicle: 1998.99 Ford Ranger
Posts: 126
Total Props: 0
I know alot of people have done the manual hub switch, and sure that they haven't had the issue.

If it's the GEM module, how do i know what kind to replace mine with.
I have a 98 ranger 4x4 that i may be parting out, and wonder if it's GEM module would work. But that truck has power windows/locks, cruise, and other stuff that mine doesn't have.

I found alot of GEM modules on ebay and probably can find one in a local junkyard, but if it comes down to replacing it, how do i know which one to get and will work for my truck?

Also, if its the shift motor? i read a write up on how to rebuild them, or something, just wondering if that would be starting point??

Hopefully someone will chime in.

Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: expo light visors and dome light (florida) billabong98z Interior, Exterior, Electrical, & Misc. 11 10-08-2010 09:36 AM
A broken dome light took out my 4x4 HarryTasker Drivetrain Tech 7 10-29-2009 02:39 PM
Gray/black OHC, Taurus Dome Light, Stock 3 bulb dome light- GA MugenCRX04 Interior, Exterior, Electrical, & Misc. 10 08-03-2009 07:11 PM
Explorer/Mustang Dome light vs. Stock 3 bulb Dome slowrey Interior Semi-Tech 15 05-23-2009 08:05 PM
Cargo Light and Dome Light Mykhael General Technical & Electrical 1 06-26-2005 03:57 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:03 PM.