99 3.0 V6 engine issue - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 08-28-2013
Thread Starter

I am: Seth
Join Date: Aug 2013
Location: canoga Park, ca
Vehicle: 199 Ford Ranger 3.0 V6
Posts: 1
Total Props: 0
99 3.0 V6 engine issue

Whats up,

I have a 99 3.0 v6 flex fuel with a running issue. I just has the motor and tranny rebuilt about 1.5 years ago and a little over 36,000 miles on them. Recently, I was driving and noticed it idling rough and almost zero power. When its cold is runs completely fine, drives like a champ. When it hits normal running temp, as per my temp needle, its idles rather rough and power loss. I was getting codes for cylinder misfire in #2 and #6 as well as a lean bank code. Replaced the coil, the codes haven't yet came back, but still have the same running issue.

A mechanic did a compression test on only 1 cylinder, #2, and found it has only 65psi and did a smoke test in the cylinder and found smoke to come out of my oil filler cap. Fuel pump tested 45-50psi.

Ive read a lot of different things and nothing is really definitive on what my problem might be. Im not looking forward to a possible rebuild again. Perhaps this is a cracked cylinder head between valve seats, or broken valves seats....im just looking for a little insight before I drop loads of cash again.

when I rebuilt the motor I replaced a lot of parts as well.

EX: EGR, Crank Pos. Sensor. Fuel filter. Coil, Plug wires, Plugs, radiator. There is more but I honestly cant remember off the top of my head.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
trans issue, and i mean issue rangerdanger01 Drivetrain Tech 2 01-09-2011 12:13 PM
Is it a timing issue or a fuel issue? Drewbis SOHC - 2.3L & 2.5L Lima Engines 7 08-13-2010 06:16 AM
check engine light + idle issue Alucard 4.0L OHV & SOHC V6 Tech 9 08-25-2009 02:18 PM
Check Engine Flashing - Ongoing Issue :( Prerunner-Ranger General Technical & Electrical 37 06-26-2009 10:21 AM
Check Engine light issue dmety87 SOHC - 2.3L & 2.5L Lima Engines 11 06-14-2007 06:45 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:32 AM.