Engine seems to miss ? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 02-26-2006
Thread Starter

I am: Rus Radcliff
Join Date: Feb 2006
Location: Parkersburg West Virginia
Vehicle: 1991
Posts: 1
Total Props: 0
Engine seems to miss ?

I have a 91 ranger with the 2.9 in it and it has been stored in the garage for almost a year now . It has only been started maybe 6 or 8 times since it was stored , when I put it away last year it ran great ! I pulled it out today and was going to get it ready to drive but it runs like crap now ? It idles really ruf but once you get it going it seems to be ok ? Any idea's on this ruf idle ? Thanks in advance for any help !
Reply With Quote
+ 0 -
Old 02-26-2006
I am: Tim Walsh
Join Date: Jun 2005
Location: Havertown,PA
Vehicle: 2010 Ford Sport
Drive Type: 4x2
Engine: 4.0
Posts: 431
Total Props: 0
bad gas. try putting some lucas fuel treatment in tank. it cleans up skunky gas.
Reply With Quote
+ 0 -
Old 02-26-2006
Trevelyn1015's Avatar
Still El Presidente...
I am: C. D.
Join Date: May 2004
Location: Texas
Vehicle: A Truck
Posts: 4,900
Total Props: 3
spark plugs/wires?
Reply With Quote
+ 0 -
Old 02-26-2006
NicksterSVT's Avatar
I am: Nick B
Join Date: Apr 2005
Location: NC
Vehicle: 01 4x4 4.0sohc edge?
Posts: 1,955
Total Props: 0
The 2.9s were bad about injectors as well... It could be something in the ignition or in the fuel injection, or it could be a lifter that isnt pumping up also. Get a 302 and no more worries...
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
seems to miss fire 894banger 2.9L & 3.0L V6 Tech 3 05-04-2011 06:50 AM
Engine miss rangermark General Ford Ranger Discussion 0 01-31-2010 07:42 AM
Freaky engine miss rangermark General Ford Ranger Discussion 5 09-25-2009 12:42 AM
Engine miss wtk General Technical & Electrical 1 11-28-2007 09:11 AM
4.0 engine miss possible electrical??? budbaringer General Technical & Electrical 0 04-17-2007 06:56 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:24 PM.