Help Ranger Misses - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 02-17-2011
Thread Starter

I am: Bob Smith
Join Date: Feb 2011
Location: Memphis,In
Vehicle: 1999 ford ranger
Posts: 1
Total Props: 0
Help Ranger Misses

I have a '99 Ranger 3.0 flex fuelthat runs fine cold...when it gets warm it starts missing on the right bank..Cyls 1, 2 & 3...I have replaced the plugs, coil pack, wires , checked compression. all cyls have 130-140psi..I have put a new O2 sensor in the right side, cleaned the mass air flow sensor and the cold air sensor in the intake tube...Can anyone help
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
93 Ranger 2.3 misses under load at take off and mid throttle 93rangerbamaboy SOHC - 2.3L & 2.5L Lima Engines 1 01-15-2014 04:37 PM
My turn with the misses Puddinhead 2.9L & 3.0L V6 Tech 24 04-23-2011 06:32 AM
when it snows it misses!!! jrex General Technical & Electrical 5 12-10-2010 06:57 PM
96 Ranger Stalls and Misses when Accelerating and Low RPM's acleme1 2.9L & 3.0L V6 Tech 1 10-03-2008 06:32 AM
Misses letting off of throttle ckbwv SOHC - 2.3L & 2.5L Lima Engines 0 03-30-2008 06:40 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:49 PM.