Idle trouble at running temp - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 04-18-2016
Thread Starter

I am: Anthony
Join Date: Feb 2016
Location: Hawesville, KY
Vehicle: 2005 Ranger FX4
Drive Type: 4x4
Engine: 3.0
Posts: 6
Total Props: 0
Idle trouble at running temp

Hey, looking for any help at all please! I have an 05 ford ranger and the CMP sensor had went out on me and motor locked up. Me and my father in law just rebuilt a 00 Taurus 3.0L engine and converted it to fit and run in my Ranger. Everything is in hooked up and will start and run perfect, when it's cold. Engine will idle at 1000rpm when it's cold. After the thermostat opens up and engine starts getting warmer when I rev it up a bit here and there the rpms drop to around 750 and starts to have a rough idle. When's it's all the way at normal running temp if I even touch the throttle it will rev but when it drops to an idle I goes all the way down until engine quits. Any good ideas on diagnosis?
Reply With Quote
+ 0 -
Old 04-20-2016
uksparky's Avatar
I am: glenn
Join Date: Dec 2015
Location: los alamos ca
Vehicle: 2003 ford ranger
Drive Type: 4x2
Engine: 3.0
Posts: 54
Total Props: 0
First thing i would do is check the idle control valve it sits on top of the intake at the front.....and the vac leaks if you have any
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle and trouble shifting Mogley 2.9L & 3.0L V6 Tech 0 01-17-2011 05:20 PM
Engine trouble... High idle still! :( acer87782000 2.9L & 3.0L V6 Tech 12 10-25-2009 01:21 PM
OHC temp trouble Mykhael General Ford Ranger Discussion 2 11-25-2007 08:41 PM
Trouble Trouble.. Alex98 4.0L OHV & SOHC V6 Tech 0 11-10-2007 03:22 PM
More cold weather, more idle trouble CAW General Technical & Electrical 8 04-03-2006 05:57 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:18 AM.