Injectors not firing - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-10-2016
Thread Starter

Member
 
I am: Nikolas
Join Date: Oct 2016
Location: Texarkana texas
Vehicle: 1999 Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 5
Total Props: 0
Injectors not firing

I have a 3.0 ranger that has been swapped and I've run into a problem. Well I've tested my injectors and they work but they don't on the truck wiring, I'm getting 12 volts on a red wire, I assume the other ones are for ground on the pcm, if I'm correct, can someone tell me how I can fix this.
Reply With Quote
+ 0 -
  #2  
Old 10-11-2016
EaOutlaw's Avatar
Member
 
I am: Kevin Nelson
Join Date: Apr 2016
Location: Lake Worth
Vehicle: 2002 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 91
Total Props: 1
Your post leaves a lot to the imagination, I assume you replaced your at one time running 3.0 for another 3.0 of the same year or close to it engine.
When doing this did you swap over your known good engine parts, accessories, etc from the old engine to the new to you engine?
Did you double check all your electrical connections to make sure they are all plugged in properly? Did you look for crushed or pinched harness wires?

When you claim the injectors are not functioning, did you use a noid light to check for injector reference pulse?

Did you confirm the fuel rail has pressure on it while cranking?
Did you confirm you have spark ?
Did you check all the ground wires to make sure they are installed and grounded properly?
Did you scan the computer for codes?
Give us more information and perhaps we have a chance to help.
Reply With Quote
+ 0 -
  #3  
Old 10-11-2016
Member
iTrader: (1)
 
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,950
Total Props: 92
Is CKP(crank position) sensor plugged in?

Computer starts spark and fuel injectors when it sees that crank is turning, via pulses from CKP sensor.
No CKP pulses = no spark and no fuel injectors

And on 3.0l, no CPS(cam position sensor) pulses = spark, but no fuel injectors


1999 3.0l Ranger also had PATS(passive anti-theft system)
PATS disables fuel injectors if correct Ford PATS Key is not used or is unable to be read by PATS module.
PATS keys have a unique ID number inside, it is read by the PATS system when key is turned on, that unique number is compared to a 4 number list added at the factory, if match is found fuel injectors are enabled, if no number or no match then fuel injectors are disabled.
PATS wouldn't be effected by engine swap, but would be if computer was swapped.

1999 PATS used a PATS module(above glove box) and it was "married" to the PCM(computer) at the factory, so they are a matched set and have to be swapped together or a Ford Dealer can "remarry" units if only one needs to be changed.

Most mobile locksmiths can make and add PATS keys to the PATS system, but can't "remarry" PATS Module and PCM.
Reply With Quote
+ 0 -
  #4  
Old 10-11-2016
Thread Starter

Member
 
I am: Nikolas
Join Date: Oct 2016
Location: Texarkana texas
Vehicle: 1999 Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 5
Total Props: 0
Quote:
Originally Posted by RonD View Post
Is CKP(crank position) sensor plugged in?

Computer starts spark and fuel injectors when it sees that crank is turning, via pulses from CKP sensor.
No CKP pulses = no spark and no fuel injectors

And on 3.0l, no CPS(cam position sensor) pulses = spark, but no fuel injectors


1999 3.0l Ranger also had PATS(passive anti-theft system)
PATS disables fuel injectors if correct Ford PATS Key is not used or is unable to be read by PATS module.
PATS keys have a unique ID number inside, it is read by the PATS system when key is turned on, that unique number is compared to a 4 number list added at the factory, if match is found fuel injectors are enabled, if no number or no match then fuel injectors are disabled.
PATS wouldn't be effected by engine swap, but would be if computer was swapped.

1999 PATS used a PATS module(above glove box) and it was "married" to the PCM(computer) at the factory, so they are a matched set and have to be swapped together or a Ford Dealer can "remarry" units if only one needs to be changed.

Most mobile locksmiths can make and add PATS keys to the PATS system, but can't "remarry" PATS Module and PCM.
the sensors you've listed are new, but in symplistic terms, what your saying is that if I have a different computer in the truck than what is actually supposed to be there I have to put the other one in? That does make sense because I pulled the good 3.0 out of an 01 and its wiring harness, well we had to rewire the alternator because the harnesses were different, the 01 was built in the 99 was on the harness, so we just wired another into the 01 so we could run it, the truck ran fine for several day but then one day it started up for like 3 seconds and began to stall or die within 5 seconds.

Last edited by Nikgt500; 10-11-2016 at 01:55 PM. Reason: Add info
Reply With Quote
+ 0 -
  #5  
Old 10-11-2016
Member
iTrader: (1)
 
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,950
Total Props: 92
Didn't follow what you said but................

1999, and up, Rangers with V6 engines had the PATS system, so you can't change computers from one vehicle to another without changing keys or having it programmed.

It wouldn't "one day" not start, or run rough, it wouldn't run at all, no fuel at all.
1999/2000 may or may not have starter motor interrupt, so starter motor wouldn't even work if it was a PATS issue.
2001 and up for sure had starter motor interrupt
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Injectors not firing. 1994 3.0 jalex88 2.9L & 3.0L V6 Tech 2 06-20-2015 04:37 PM
Not firing on front coil pack #2-#3? Plz Help! robuga SOHC - 2.3L & 2.5L Lima Engines 4 11-15-2010 07:51 AM
2.9L EfI #3 cyl. not firing? papperbob1 2.9L & 3.0L V6 Tech 1 11-01-2010 09:44 PM
Truck not firing just turning over...???? 8-ball 2.3L & 2.5L I4 Tech 22 08-19-2008 07:35 PM
Cylinders 2 and 3 not firing on intake side - 92 2.3 DIS CaliGold SOHC - 2.3L & 2.5L Lima Engines 5 09-03-2006 01:19 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 08:23 AM.