missing - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 05-24-2010
Thread Starter

I am: mike ledbetter
Join Date: May 2010
Location: hermitage tn
Vehicle: 2004 ford ranger
Posts: 2
Total Props: 0

installed a engine from salvage yard in my 2004 ranger 3.0 it misses , if I move spark plug wires to different place it runs better , I have double checked most everything ., please help is it the camshaft position sensor
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
OHC wires... Missing one? Gearhead61 General Technical & Electrical 6 02-19-2006 04:34 PM
missing that honk KARPE General Technical & Electrical 9 01-11-2006 06:35 PM
Am I missing something on my intake??? W/ pic Fx4wannabe01 4.0L OHV & SOHC V6 Tech 24 12-19-2005 07:51 PM
Rear Brake Parts missing Morph Drivetrain Tech 10 10-30-2005 04:58 PM
Lets play a game.. "Missing Coolant" rngprerunner General Technical & Electrical 10 06-30-2005 07:16 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:01 PM.