Missing coolant - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-05-2009
Thread Starter

Member
 
I am: Hank Anderson
Join Date: Oct 2009
Location: Little Rock
Vehicle: 1999 Ford Ranger
Posts: 1
Total Props: 0
Missing coolant

I've refilled my coolant several times over the past few days, but every time I go back to check the level, the cap on the coolant tank is off and the tank itself is empty. I know the level will fluctuate depending on how long you've been driving, but the tank shouldn't be completely empty. I can tell from the underside of the hood that the coolant has exploded outward from the tank- is there any reason my coolant tank is getting too pressurized? Any help would be much appreciated-
Reply With Quote
+ 0 -
  #2  
Old 10-05-2009
littlered's Avatar
Member
iTrader: (2)
 
I am: Zach Heindselman
Join Date: Sep 2008
Location: Lewistown, Mo
Vehicle: 1998 Ford Ranger
Posts: 1,541
Total Props: 1
it could be maybe that it is getting to hot. have you noticed a change in your temp gauge?
Reply With Quote
+ 0 -
  #3  
Old 10-05-2009
Member
 
I am: Ken Here
Join Date: Mar 2007
Location: Upstate,NY
Vehicle: 2003,Ranger
Posts: 2,598
Total Props: 13
1- Bad thermostat
2- Bad water pump
3- Bad head gasket

Most probable is option 3
Reply With Quote
+ 0 -
  #4  
Old 10-06-2009
Daily Driver's Avatar
Member
 
I am: Joe Blough
Join Date: Oct 2007
Location: NH
Vehicle: 1995 Ford Ranger
Posts: 191
Total Props: 0
x2, especially on 3. Let's hope not. I may have the same issue. After it gets hot, if you turn it off for an hour or so, see if the top hose collapses. It may be intermittent. That is another indicator of a head gasket issue.

Is your coolant good? Too much water? Mine was, long story. I just changed it. Hoping that fixes it. doubt it.
Reply With Quote
+ 0 -
  #5  
Old 10-15-2009
RedRanger91XLT's Avatar
Member
 
I am: Mike Maughan
Join Date: May 2009
Location: Woodbridge, VA
Vehicle: 1991 Ford Ranger
Posts: 316
Total Props: 0
Usually if you have a bad T-stat it will cause the coolant to back up.
Reply With Quote
+ 0 -
  #6  
Old 10-15-2009
OVERtheEDGE's Avatar
Member
 
I am: matt richardson
Join Date: Mar 2008
Location: locust grove georgia
Vehicle: 1998 ford ranger
Posts: 1,441
Total Props: 0
i have that problem too. its my headgasket for sure
i have the 4.0 though
Reply With Quote
+ 0 -
  #7  
Old 10-15-2009
RedRanger91XLT's Avatar
Member
 
I am: Mike Maughan
Join Date: May 2009
Location: Woodbridge, VA
Vehicle: 1991 Ford Ranger
Posts: 316
Total Props: 0
I would check the T-stat first if I were you.
Reply With Quote
+ 0 -
  #8  
Old 10-15-2009
RangerJacoby99's Avatar
Member
iTrader: (2)
 
I am: Ryan Jacoby
Join Date: Feb 2009
Location: Thornton,CO
Vehicle: 99 Ford Ranger Sport 4X4
Posts: 374
Total Props: 0
dont forget heatercore mine went out not to long ago kinda of a pita to change!
Reply With Quote
+ 0 -
  #9  
Old 10-15-2009
RedRanger91XLT's Avatar
Member
 
I am: Mike Maughan
Join Date: May 2009
Location: Woodbridge, VA
Vehicle: 1991 Ford Ranger
Posts: 316
Total Props: 0
Those are a biznitch to do! argh!

Last edited by RedRanger91XLT; 10-15-2009 at 03:39 PM. Reason: heheh... spelled it differently...
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
OHC wires... Missing one? Gearhead61 General Technical & Electrical 6 02-19-2006 05:34 PM
missing that honk KARPE General Technical & Electrical 9 01-11-2006 07:35 PM
Am I missing something on my intake??? W/ pic Fx4wannabe01 4.0L OHV & SOHC V6 Tech 24 12-19-2005 08:51 PM
Rear Brake Parts missing Morph Drivetrain Tech 10 10-30-2005 05:58 PM
Lets play a game.. "Missing Coolant" rngprerunner General Technical & Electrical 10 06-30-2005 08:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 08:13 AM.