noise 3.0? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 08-18-2007
flaymon1's Avatar
Thread Starter

I am: Robert Briand
Join Date: Apr 2007
Location: Pendleton, IN
Vehicle: 1998-98-90 Ford Rangers
Posts: 49
Total Props: 0
noise 3.0?

A fellow Ranger owner left this question on mycardomain can you guys give any advice on what it could be?

"hey u seem to know a lot about rangers. i have a 1998 ranger 3.0 and after reaching 100 000 miles and changing the oil. ever time i drive now it makes a ticking sound that goes with the engine rps. this seem to be a common problem with the 3.0s and ford says they don't know what it could be. i thing it might be the oil pump because it doesn't sound like a valve do u know anything about this ? thanks"

Last edited by flaymon1; 08-18-2007 at 05:27 PM.
Reply With Quote
+ 0 -
Old 08-19-2007
captain bigs's Avatar
I am: Bryan M
Join Date: Jun 2006
Location: Niceville, Florida
Vehicle: 2000 Ford Ranger
Posts: 76
Total Props: 0
uh oh... my 2000 3.0 is at 91,000 hope that dont happen to me... as far as advice sry i dont kno
Reply With Quote
+ 0 -
Old 08-19-2007
Legion's Avatar
I am: Vincent R
Join Date: Mar 2007
Location: Austin, TX
Vehicle: 1996 Ford Ranger XL
Posts: 288
Total Props: 0
sometimes its the gas u pump
Reply With Quote
+ 0 -
Old 08-19-2007
Unregistered User
Posts: n/a
Total Props: 0
camshaft possition sensor?
Reply With Quote
Old 08-23-2007
mj550's Avatar
I am: M. J.
Join Date: Apr 2006
Location: USA
Vehicle: 2008 Ford Ranger
Posts: 601
Total Props: 0
Could be the CPS, or just pinging...
Reply With Quote
+ 0 -
Old 08-24-2007
Interceptor944's Avatar
iTrader: (1)
I am: Jeremy S
Join Date: Aug 2007
Location: Harrison, Michigan
Vehicle: 2002 Blk Ranger Edge 4.0
Posts: 156
Total Props: 0
Yep I found it to be pinging before...
Reply With Quote
+ 0 -
Old 11-01-2007
Jazz921's Avatar
iTrader: (2)
I am: Jerald Ford
Join Date: Sep 2007
Location: Evansville, IN
Vehicle: 2001 Ford Ranger
Posts: 997
Total Props: 1
mine is doing this as well and sometiems will run like crap until i get on it and blow the crap out and then it runs fine again for a bit but always have the ticking and it doesnt sound like pinging, its just a sharp ticking noise.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0 OHV valve noise or main bearing noise blair683 4.0L OHV & SOHC V6 Tech 4 07-09-2015 08:40 PM
Ticking noise at low speeds, lots of noise in general heaton84 General Technical & Electrical 8 11-18-2007 10:52 AM
Noise supression / shielded spark plugs and wires?? FireRanger General Ford Ranger Discussion 13 11-04-2004 05:34 AM
Squeek/Clunking noise help! Bailey General Ford Ranger Discussion 13 10-28-2004 12:29 PM
Name that Noise!! Strider0O0 General Ford Ranger Discussion 7 07-14-2004 08:06 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:32 PM.