Problem - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 12-28-2007
sonic_blue_tremor02's Avatar
Thread Starter

I am: John Daniel Phillips
Join Date: Apr 2006
Location: Ketchum,Ok
Vehicle: 2002 Ford Ranger Tremor
Posts: 80
Total Props: 0

Hey everyone..its been a while since i have been on here..well any way the other day i started my truck and it started then it started shaking and the engine juddered i thought it was because i needed gas and its done that before when i was low on i put gas in it. and i continue driving and my check engine light came one and it started juddering again...any ideas??
Reply With Quote
+ 0 -
Old 12-30-2007
I am: Carl Darnell
Join Date: Dec 2007
Location: Taylorsville Ky
Vehicle: 2003 Ford Ranger Edge
Posts: 289
Total Props: 0
Have you tried cleaning the IAC valve? That seems to cause a lot of idle and dying at take off problems. If it helps it you may have to replace it to really fix it for good. I need one for my Aerostar and it's about $65.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 05:58 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:57 PM.