Starting Problem - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 06-17-2009
Thread Starter

I am: Kyle Weldon
Join Date: Jun 2009
Location: Waterdown, Ontario
Vehicle: 1999 Mazda B3000
Posts: 1
Total Props: 0
Starting Problem

i have a 3.0 v6 1999 mazda b3000 with just over 100k on it. last week i went to start my truck at the store and she wouldent go... just a ticking/buzzing noise comming from the starter. tried a boost - no go. tried smacking the starter with a hammer - no go. took the battery cables off, cleaned them and tightend them right up - no go. i got a tow to my house and as soon as it was off the truck it started right up! it was working fine for a few days then it wouldent start again. this time not even a noise when i turned the ignition. all sources say its the starter so i replaced it and tried to fire it up again - no go. put a different battery in it with a full charge - still nothing. the only noise the truck makes is a tonne of clicking comming from the fuze box under the hood and under the dash. relays going crazy? i would think something is not grounding out but i figured i would check with the experts for ideas.

any sudgestions would be greatly appreciated. thanks guys
Reply With Quote
+ 0 -
Old 06-17-2009
I am: Tim Walsh
Join Date: Jun 2005
Location: Havertown,PA
Vehicle: 2010 Ford Sport
Drive Type: 4x2
Engine: 4.0
Posts: 431
Total Props: 0
Could be fuel cut off switch.I had same happen to me once in a escort.Had it towed and got off truck started right up. I would check that out.
Reply With Quote
+ 0 -
Old 06-17-2009
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
Do all your other electrical devices still work, i.e., Head lights, dash lights, turn signals, blower motor, etc. when this happens?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 10:33 AM
Diagnose this (possibly) simple no-starting problem bleech1 4.0L OHV & SOHC V6 Tech 12 11-25-2008 04:26 PM
starting problem...kinda yellow_edge General Ford Ranger Discussion 2 08-31-2008 03:34 PM
Starting Problem Need help asap Shadowviper SOHC - 2.3L & 2.5L Lima Engines 8 11-16-2005 02:02 PM
Major Starting problem !! Help !! Mootz 4.0L OHV & SOHC V6 Tech 4 04-28-2005 06:45 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:16 AM.