4.0 '93 Ranger NO START - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 05-26-2011
Thread Starter

I am: Tyler Norris
Join Date: May 2011
Location: Gamaliel, KY
Vehicle: '96 & "93 Ford Ranger
Posts: 2
Total Props: 0
4.0 '93 Ranger NO START

hello all, im new to the forum an need all the advice i can get.
im not very auto savy so bear with me
i have a 1993 ford ranger 4.0 5 speed on airbags.
i purchased the truck about a year ago not running.
the truck turns over but will not start.

i have

-drained the tank an put in fresh fuel
-checked an cleaned a few grounds,
-located an reset the inertia switch
-an cleaned the MAF sensor

due to hard times im on a tight budget an need to kno everything i should check b4 i start replacing parts...
also wanting to kno if there is a detailed DIY step by step guide of what i need to Check/Clean/buy.
Reply With Quote
+ 0 -
Old 05-26-2011
I am: Larry Rantz
Join Date: Feb 2011
Location: Ontario, Canada
Vehicle: 1995 2.3L Ranger
Posts: 27
Total Props: 0
Check for spark. If no spark suspect coil(s), crank or cam sensor, (I think they'll still run without a cam sensor, but I can't recall), or it could be the ignition module. I believe the 93 year was one of the last before ignition module was integrated into the PCM.

Can you hear the fuel pump run when you turn the key to "ON"? If it runs, does it give proper pressure? I don't know for certain what the 4.0's need, but I imagine it's 30 PSI or higher.

Thats what you should check first, I think.
Reply With Quote
+ 0 -
Old 05-26-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
I am: Alex P
Join Date: Dec 2010
Location: Flat Rock, Mi
Vehicle: 1999 XLT off road.
Posts: 6,313
Total Props: 49
Truck needs two things to run. Fuel and Spark. check those systems first.
Reply With Quote
+ 0 -
Old 06-03-2011
I am: Danny Crews
Join Date: Jun 2011
Location: Normal, IL
Vehicle: 1997 Mazda B4000 4x4
Posts: 1
Total Props: 0
I had same issue a few years ago. Check the wire attachment to the crank sensor on bottom of engine. Try disconnecting and cleaning the electrical connection. I found this by accident, but haven't had a problem since.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
only start on easy start kyde General Technical & Electrical 2 05-25-2014 05:17 AM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 07:07 AM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 09:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 04:27 PM
Ranger won't start edgecellent02 2.3L & 2.5L I4 Tech 27 07-22-2008 05:38 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:23 AM.