Bad Idle - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-14-2017
Member
Thread Starter
 
Join Date: Jun 2011
Location: Olive Branch,Ms
Posts: 2
Icon4 Bad Idle

I have a 2001 ranger XLT with 4.0 SOHC 129,000 miles. It has a bad idle, sometimes it will die if rpms are not raised to 1000-1200. New to me vehicle, so I filled with gas and Seafoam. ( check engine light on ). Then I drove 300 miles to arrive home. Still same problem! I replaced PVC valve ( was no good ) I bought ford replacement spark plugs and a set of wires, also bought a new fuel filter. The local Autozone ran codes of PO300 ( random misfire detected ) and PO171 Fuel system too lean ( cylinder bank 1 ) also PO174 Fuel system too lean ( cylinder bank 2 ). Any suggestions on any problems I should concentrate on to resolve the problem. Note: Truck runs fine at speed in city and highway.

Last edited by mazdainOB; 02-14-2017 at 01:51 PM.
Reply With Quote
  #2  
Old 02-15-2017
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 5,746
Welcome to the forum.

Most common issue on the 4.0l SOHC for your symptoms is the PCV hose elbows, they crack on the under side and look great from above but cause rough idle and Lean codes

Good read here on that: PCV Elbow - Fix for a very common CEL!


Also Clean the MAF sensor, should be done every year or so, you do need to use electronic or MAF cleaner which doesn't leave a residue, but it is a simple spray it on and let it dry, so not at all hard to do.


The 1997 to 2004/5 4.0l SOHC engines also had a timing chain tensioner issue, not related to your problem, just a heads up
There are 3 tensioners, 2 can be changed without too much work, and they are the ones that tend to fail
When these started to fail the chain would get loose and beat on the guides, the guides would break and you would start to get a rattle in the engine.
Engine needed to be pulled out to change rear timing chain guides and chain, so not an easy fix
Reply With Quote
  #3  
Old 02-16-2017
Member
Thread Starter
 
Join Date: Jun 2011
Location: Olive Branch,Ms
Posts: 2
Thanks RonD, I have cleaned the MAF sensor with electronic cleaner and replaced pcv and inspected hose elbow and all of attached hose to pcv. Idle did not improve. So I moved to spark plug and wires. I am replacing them a few at a time as my health will allow. The old plugs are worn out !!! They have a gap of 100+, no tips left. Bought replacement plugs from Ford dealer, same same as orginal. will up date thread when I finish plugs and wires. Thanks for the info about the MAF sensor cleaning, will do every spring check on the vehicle.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
low idle when slowing down to idle j_huhnke 4.0L OHV & SOHC V6 Tech 2 03-25-2012 09:26 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 11:49 AM
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 06:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 11:50 AM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 07:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:36 AM.