Bad temp sending unit? Bad thermo? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 12-02-2010
__Arod__'s Avatar
Thread Starter

I am: (A)lex (Rod)riguez
Join Date: Apr 2010
Location: Central Florida
Vehicle: 2011 Sport
Drive Type: 2wd
Engine: 4.0
Posts: 286
Total Props: 0
Bad temp sending unit? Bad thermo?

Truck runs fine. Its cold out so im blasting the heat and thats working fine. But my gauge drops to C when its on. So I turn the heat off and it goes right back to normal. it never goes past normal reading temp. Im pretty sure its not a bad thermostat cause my heat would be wierd. Just wanted to know if maybe its one of the plugs on the thermostat housing

-2001 4.0
Reply With Quote
+ 0 -
Old 12-02-2010
Alex98's Avatar
I am: Alex
Join Date: Jul 2007
Location: Baltimore, Maryland
Vehicle: 1998 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 841
Total Props: 0
maybe the thermostat is stuck open, if you have a scan tool look at the temp readings. it could be a bad sending unit but i doubt it.
Reply With Quote
+ 0 -
Old 12-03-2010
jtfoxman's Avatar
I am: JT Fox
Join Date: Jun 2005
Location: The Poconos
Vehicle: 1997 Ford Ranger XLT Supe
Posts: 891
Total Props: 0
I would think if the stat is stuck open it would always run cold. Maybe the wrong stat? What temp stat is in there now. I had the same issue until I changed to a 195 stat.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
just changed thermo plz help! 02FX4U 4.0L OHV & SOHC V6 Tech 17 10-11-2011 04:20 PM
Bad sending unit? StxDangerRanger General Technical & Electrical 4 07-21-2011 04:01 PM
TEMP. GUAGE SENDING UNIT kwhitmer83 General Technical & Electrical 7 11-13-2010 09:42 PM
5R55E Temp Sending Unit kawa General Ford Ranger Discussion 20 05-08-2010 11:35 AM
Temp sending unit Diabolic 2.3L & 2.5L I4 Tech 6 02-21-2008 02:48 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:33 AM.