CEL- No Overdrive - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-21-2007
Thread Starter

Member
 
I am: Jonathon Walters
Join Date: Feb 2007
Location: Upton
Vehicle: 1996 Ranger 2.3
Posts: 12
Total Props: 0
Icon5 CEL- No Overdrive

A month or so ago the CEL came on in my '93 4.0 auto ranger. I was cruisin at about 60 and it jumped down a gear(pretty hard) and never would go back into OD. Then i find that it doesnt idle very good and even dies sometimes. I've covered the small things like, IAC and MAF. Every now and then the light goes off, OD comes back and all is well for a few minutes. And if it has anything to do with it at all, my valve cover started leakin at about the same time..im stumped. Anybody have any ideas...this thing is drivin me crazy.
Reply With Quote
+ 0 -
  #2  
Old 03-22-2007
rwenzing's Avatar
RF Veteran
iTrader: (4)
 
I am: Bob .
Join Date: Nov 2004
Location: Michigan
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 5.0
Posts: 7,773
Total Props: 19
The CEL is telling you that a Diagnostic Trouble Code is stored. Until you know the code or codes, you will just be guessing.
Reply With Quote
+ 0 -
  #3  
Old 03-22-2007
greygooseranger's Avatar
Member
 
I am: Chris .
Join Date: Apr 2006
Location: SE Michigan
Vehicle: 2004 Xcab Edge 4.0 5spd m
Posts: 3,293
Total Props: 0
I know when this happend to me in my Bonneville, it was the TPS that was off. That car had an adjustable one. When it needed to be adjusted a CEL light came on and would not shift into OD. Just a thought.....
Reply With Quote
+ 0 -
  #4  
Old 03-22-2007
Thread Starter

Member
 
I am: Jonathon Walters
Join Date: Feb 2007
Location: Upton
Vehicle: 1996 Ranger 2.3
Posts: 12
Total Props: 0
I changed the TPS, still nothing. Autozone ran the scanner on it and they told me the EGR valve was messed up....it doesnt even have one....
Reply With Quote
+ 0 -
  #5  
Old 03-24-2007
Thread Starter

Member
 
I am: Jonathon Walters
Join Date: Feb 2007
Location: Upton
Vehicle: 1996 Ranger 2.3
Posts: 12
Total Props: 0
Finally got it fixed. Apparently the MAF was more than dirty. I replaced it and everything is good to go.
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
What exactly is overdrive? jtslmn720 2.9L & 3.0L V6 Tech 21 12-12-2008 08:17 AM
When To Use Overdrive (OD) NancyDarcy 2.9L & 3.0L V6 Tech 13 01-03-2007 09:08 AM
Overdrive light just comes on and blinks??????? Sting00 Ranger-Forums Office 7 07-27-2006 06:41 PM
overdrive question for those with an auto 4.0L crawly1025 4.0L OHV & SOHC V6 Tech 7 06-05-2006 12:13 PM
Overdrive problem jojosdad Drivetrain Tech 1 03-12-2006 12:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 08:14 AM.