Got some codes, didn't know if anyone else has had these problems. - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 06-19-2010
waterfowler07's Avatar
Thread Starter

I am: Tyler Honey
Join Date: May 2008
Location: Old Town, ME
Vehicle: 2002 Ford Ranger
Posts: 131
Total Props: 0
Got some codes, didn't know if anyone else has had these problems.

Hey, it's been a while since I've posted, but I just got the truck scanned, and I've got some codes that I've found on here, but most are on OHV's. I've got codes P0300, P0171, and P0174. I've read on here about the PCV valve, but that seems ok. I was gonna get a new coil, plugs and wires because they're original still and have 120000 miles, but if I don't have to I don't want to throw the cash because I have to redo the brakes on all four corners. I've gotten the 4.0 cover off of the intake and unplugged the TPS, and that didn't seem to do much. I also unplugged the MAF and it kicked right up to where idle should be and run fine, but when it was plugged in, it bogged down again. I've also removed the pipe from the PCV valve to the intake hose, and it just about stalls, so I'm leaning towards a bad MAF. My air filter was wicked dirty when I checked yesterday. There is also a terrible hissing under the hood, don't know if that's related or not. So thanks, I appreciate it.

2002 XLT 4x4...3" PA Body Lift...33x12.50x15 Pro Comp M/T's...Flowmaster Original 40 Si/Do...Black Headlights...Fog Light Mod

Last edited by waterfowler07; 06-19-2010 at 10:25 AM. Reason: Looked around the engine some more
Reply With Quote
+ 0 -
Old 06-21-2010
djfllmn's Avatar
I am: DJ Fillman
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Total Props: -4
the hissing means you have a vacuum leak somewhere...check the hose that leads from the air inlet tube to the pcv valve theres a good possibility it split
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
For those that didn't know..... Jimmeh Snapshots 18 05-26-2009 04:27 AM
Didn't know they made Edge's in that body style Igobytwitch General Ford Ranger Discussion 19 01-08-2009 08:51 PM
Has anyone had problems with 4 wheel parts? fx2offroadranger General Ford Ranger Discussion 11 10-02-2007 03:15 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:30 AM.