Knocks when started - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 03-19-2014
Thread Starter

I am: Jeffrey Kraft
Join Date: Mar 2014
Location: Lake Havasu
Vehicle: 2003 Ranger XLT
Drive Type: 4x2
Engine: 4.0
Posts: 1
Total Props: 0
Knocks when started

I have a 2003 Ford Ranger with very low miles, I had just put on a new fabtech 3 inch lift kit on my truck. The lift consisted of front lowered spindles and add a leaf in the rear. When i first finished and put the truck back on the ground and i first started it, i heard a strange knock that happnens only when it kicks over and start. You can sometimes here it when you rev the engine a little. (The truck does not have any body lift)*. Does anyone have any idea what this could be? Or has the same problem?
Reply With Quote
+ 0 -
Old 03-19-2014
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,738
Total Props: 88
You will just have to look around the engine and trans to see where it is hitting.

Put E-brake on then put into D or First(feather clutch), rev engine a bit, engine and trans should move a bit and make the knock noise.
Also try Reverse gear with same method, see if you can track it down.

Could even be some new part that didn't get tight enough, starting and reving engine torques frame a bit.
Reply With Quote
+ 0 -
Old 03-19-2014
03edge's Avatar
iTrader: (1)
I am: Israel M
Join Date: Feb 2009
Location: Akron, OH
Vehicle: 2003 Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 1,031
Total Props: 1
Is it a knock or a tick? Leaking manifolds and or exhaust will sound like a ticking noise under acceleration
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Started to build my new Sub Box (Pics inside) Strider0O0 Audio & Video Tech 67 01-23-2007 07:18 AM
runs rough when started soemtimes 93rangerxlt4.02007 4.0L OHV & SOHC V6 Tech 28 10-18-2005 08:14 PM
started putting in a do it your self bed liner 04edge Exterior Semi-Tech 22 08-12-2005 05:28 PM
Show date thread was started? jmacmaster Ranger-Forums Office 1 12-03-2004 05:06 PM
Exterior/Interior---first mod POLL STARTED Mudhippy Exterior Semi-Tech 36 11-13-2004 03:03 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:19 PM.