missing hoses?? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 04-02-2016
Thread Starter

I am: Jake
Join Date: Dec 2015
Location: Bristol va
Vehicle: 2005 Ranger
Drive Type: rwd
Engine: 4.0
Posts: 10
Total Props: 0
missing hoses??

well as the title says im missing a couple vaccum hoses it appears... rough idle, kinda struggles when i get on the gas a bit. i remember running into the 2 hoses last time i changed the tstat housing. but since then i had to send my truck to a mechanic and eventually had him drop a new engine into it. now aside all the idle issues and all that it runs great. all the symptons pointed towards a pcv valve but as i was looking i have the hose that runs to the back of the valve cover on the driver side. but im missing the 2 on either side of it. if i just knew where they were supposed to go to from there id get them put back on.. but i have no idea and i dont like running it the way its going. any and every bit of information is appreciated. pics would be wonderful. thanks in advance!
Attached Thumbnails
missing hoses??-14596297052921216414247.jpg   missing hoses??-14596298197881819487389.jpg  

Last edited by kaptnredbeard; 04-02-2016 at 02:52 PM.
Reply With Quote
+ 0 -
Old 04-02-2016
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,754
Total Props: 88
Here is an article, with pictures, of thermostat housing swap: How To Replace the Upper and Lower Thermostat Housing on a Ford 4.0L V6 SOHC Engine

May be it will jog the memory

Also here: Need help with vacuum lines! - Ford Explorer and Ranger Forums "Serious Explorations"

And here: Ford Explorer and Ranger Forums "Serious Explorations" - View Single Post - Code PO171, PO174 Help
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Pic request....steering rack hoses Fx4wannabe01 Suspension Tech 4 09-04-2007 10:56 PM
Where do these hoses go? Marcaronio 2.9L & 3.0L V6 Tech 18 06-23-2007 01:48 AM
Brake hoses too short Oh5Edge General Technical & Electrical 12 12-01-2006 04:44 PM
radiator hoses RNGMSTR 2.3L & 2.5L I4 Tech 2 10-23-2006 03:37 PM
can anyone show me how to extend hoses? TippnOver Drivetrain Tech 17 01-17-2005 04:15 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 09:26 AM.