my truck is loosening up or something... idk - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 02-07-2008
sambob117's Avatar
Thread Starter

I am: Sam Guenther
Join Date: Nov 2006
Location: Rochester, NY
Vehicle: 2003 Ford Ranger XLT 4x4
Posts: 1,124
Total Props: 0
my truck is loosening up or something... idk

All of a sudden (a while back actually) my idle rpm's dropped a bit, used to sit a little over 1k and now it sits under 1k at idle, not sure what was normal, but now it doesn't seem to want to roll forward after I let off the break, not sure if this matters. Also my breaks feel like they've lost pressure or something, my foot is going a lot lower when I'm coming to a stop. It feels like the pedal is traveling a bit before it engages the brakes, but not 100% of the time, every once in a while it feels very solid, usually at higher speeds. Fluid levels all look fine, so I have no ideas.

2003 4.0L SOHC Ford Ranger 4x4
Mods: Pioneer head unit, K&N drop in filter, Screamin Demon Coil pack, Underdrive pulley, Xcal 2, JD Traction bars, 31X10.5X15 Sidewinders

My Truck Domain

"Gonads are useful for their purpose, but they are no substitute for brains." -Paul Harvey

"If you think Education is difficult, try being stupid".
Reply With Quote
+ 0 -
Old 02-07-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
I am: Shane B
Join Date: May 2005
Location: Boring, Oregon
Vehicle: 2001 Ford Ranger
Posts: 21,721
Total Props: 8
Mine idles right at about 720-750rpms. Your problems might be the result of a damaged vaccum line. But that's my guess.
Reply With Quote
+ 0 -
Old 02-07-2008
GrizzRacer's Avatar
I am: Mike W
Join Date: Aug 2007
Location: WI
Vehicle: 2002 Ranger XLT 4.0L
Posts: 63
Total Props: 0
On the brake issue, check your pads and shoes. FWIW, when my rear brakes started to go south on me, the pedal got REAL soft. New shoes and it was back to new.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
KC Daylighters Installed- PICS(56k idk) input? 04_xlt_4.0_4x4 Snapshots 49 09-16-2010 07:29 PM
idk what size to get!!!!!!! Off-roadranger04 Wheels & Tires Semi-Tech 3 04-21-2009 07:21 PM
idk bout mickey thompson tires 06fx4jb83 General Ford Ranger Discussion 23 12-26-2008 10:42 PM
BMW M3 - E92 -56k? idk Goodysgotacuda Snapshots 14 12-17-2008 01:25 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 02:18 PM.