Strange problems - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 05-25-2008
kd3yt1's Avatar
Thread Starter

I am: Butch Hinton
Join Date: Jul 2007
Location: Hollidaysburg Pa
Vehicle: 2002 Ford Ranger Edge
Posts: 24
Total Props: 0
Strange problems

Posting this in all ranger forums I am member.....

2002 Edge 4.0 44,000 miles

Today I was pulling away from a parking spot, went about 20 feet and when I applied brakes to stop, it felt like no brakes and I noted engine was racing - immediately applied more pressure on brakes and put truck in neutral. Apparently when I took foot of gas pedal to apply brake, engine did not return to idle. Shut engmne off. Started engine again, it idled ok and has run fine since. Was about 5 miles from home in the city so every time I would go to stop I of course was nervous, but truck has run fine since.

Any ideas was might has caused it?? IAC??? I did not get a check engine light at all.Put scanner on and reads "No Codes"

Could this have just been a fluke or should I be nervous every time I put brakes on.......
Reply With Quote
+ 0 -
Old 05-25-2008
I am: thomas w
Join Date: Mar 2008
Location: olean, ny
Vehicle: 2004 ranger xlt
Posts: 40
Total Props: 0
if the pedal went to the floor with no resistance then i would look at the brakes very close. my first thought when reading your post is the engine was probably overpowering the braking due to it racing. mabe the throttle cable is sticking a bit, if it does it again throw it in neutrel and pump the gas pedal fairly quick see if it returns to idle. my 2 cents anyway
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 06:35 AM
Strange electrical problems... RogerLee DOHC - 2.3L Duratec / Mazda L Engines 1 01-14-2014 05:30 PM
Strange problems.. MOTOunplugged General Ford Ranger Discussion 3 10-27-2010 07:14 AM
HELP - tranny problems! Strange rattling and very HOT to touch aweiss2k Drivetrain Tech 13 04-21-2006 08:28 AM
Strange sound from dashboard of my dad's 98 Ranger.. help? Wowak General Technical & Electrical 0 08-02-2004 09:20 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:12 PM.