Truck is bucking, sputtering and missing...Need help please! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 08-22-2012
cchsbuzz19's Avatar
Thread Starter

iTrader: (5)
I am: Clayton Busby
Join Date: Jul 2007
Location: North Canton, Ohio
Vehicle: 2008 Ford F-250
Drive Type: FX4
Engine: 6.8
Posts: 2,417
Total Props: 1
Oh I know. I mean for mine it took a week for it to throw a CEL for a misfire in Cylinder 3 but when we tried to fix it replacing the plugs and actually made it all worse the CEL went away and didn't throw another one. Stupid ha.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck is sputtering and I haven't located problem Paul Wells 4.0L OHV & SOHC V6 Tech 22 06-07-2015 08:11 AM
Over heated and now sputtering... Need help. 01 ranger 2.9L & 3.0L V6 Tech 8 07-15-2010 04:53 AM
3.0 Auto Hesitation, Sputtering, Missing When Cruising? dovegabanna 2.9L & 3.0L V6 Tech 10 07-05-2010 08:39 AM
Bucking/missing CWU10 4.0L OHV & SOHC V6 Tech 2 08-12-2009 03:54 PM
Missing Bolts - Help Please Johns777 Interior Semi-Tech 5 06-08-2008 07:14 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:18 AM.