no spark anymore and stumped - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 8-Cylinder Tech

8-Cylinder Tech If you are one of the few with a V8 engine in your Ranger, or if you dream of a Ranger with a V8 engine, this is the sub-forum for you.

LinkBack Thread Tools Search this Thread
Old 09-19-2010
Thread Starter

I am: link gee
Join Date: Jun 2010
Location: kelowna, bc
Vehicle: 1992 ford ranger xlt
Posts: 17
Total Props: 0
no spark anymore and stumped

Hey Guys,

have a 90 5.0L. v8 that i've rebuilt and i had it running there for awhile (not on the road yet, still getting the tranny rebuilt and working). so it has a reman'd distributor and like i said it was running well for abit there but now i can't get a spark. can't figure out whats going on and i've gone through the guide i've seen posted on here a few times and still not sure whats up. just wanted to verify a few things concerning wire voltages and engine codes.

with Key On Engine Off the six wires on the distributor are:

1 - 4.7v
2 - 12 v
3 - 0v (alternates up to 10v when cranking)
4 - 12v
5 - 12v
6 - 5v - ign ground wire.. is it supposed to have 5v???
are these the correct voltages when in KOEO mode?

I currently have the following engine codes:
84 - engine codes

keep in mind that i have no smog stuff hooked up (no tad, tab, or EGR stuff) and i had all of these codes before when i was getting a spark and the engine was running. I've also loosened the distributor and turned it left-right-left with the test light on both the negative and positive terminals on the coil and it doesn't pulse the light or anything it stays a constant 12v on both terminals. its a brand new coil as well. also i've checked all my grounds and they all look good.

i'm going to replace my stator in the distributor today to see if that fixes it but after that i'm completely stumped. any help would be greatly appreciated!
Reply With Quote
+ 0 -
Old 09-21-2010
I am: Mike Gasoline Alley
Join Date: Jul 2009
Location: Queen Creek, AZ
Vehicle: 94 Ranger XLT excab
Posts: 57
Total Props: 0
If you can get your hands on another EFI dizzy you could just unplug yours and plug in the test one and ground it out on the engine some where and spin it by hand with the key on and that will tell you if the dizzy in the engine is working or not. You should hear the injectors click and the fuel pump come on and the coil will spark when you spin the test dizzy.
Reply With Quote
+ 0 -
Old 12-24-2010
I am: Gary Burke
Join Date: Dec 2010
Location: Monticello,Kentucky
Vehicle: 1989 ranger
Posts: 88
Total Props: 0
pull the dist. and check the gear at the botom ,it may not be holing and not spining the top end.
Reply With Quote
+ 0 -
Old 12-27-2010
Thread Starter

I am: link gee
Join Date: Jun 2010
Location: kelowna, bc
Vehicle: 1992 ford ranger xlt
Posts: 17
Total Props: 0
Thx for the advice but i figured it out a little while ago. i had my grounds screwed up and found i had a constant 5v on the sig rtn wire and the TFI was fried. also checked the computer board and one of the traces on the board on the back was fried so i resoldered that together and replaced the TFI and she started right up.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sad Sad Sad day for me......totaled Ranger....and its not even mine anymore :( dixie_boysles Snapshots 8 03-01-2014 09:30 AM
Turn signals and hazard lights not flashing anymore DavidY General Technical & Electrical 5 04-09-2011 10:40 AM
motor swap and AC does not work anymore?? rizoss16 General Ford Ranger Discussion 3 06-23-2010 04:44 AM
Stumped... need opinions and help thesoundmaster General Ford Ranger Discussion 18 09-28-2008 06:09 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:07 AM.