2 18"s installed in 04' Explorer *pics* - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 03-08-2007
I am: Derek
Join Date: Oct 2006
Location: Dayton, OH
Vehicle: 1994 Ranger
Posts: 66
Total Props: 0
Nice install but other than that we need some TL numbers.
Reply With Quote
+ 0 -
Old 03-08-2007
greygooseranger's Avatar
I am: Chris .
Join Date: Apr 2006
Location: SE Michigan
Vehicle: 2004 Xcab Edge 4.0 5spd m
Posts: 3,293
Total Props: 0
Originally Posted by bamaboy
what do you mean whole truck?

just the cargo area, i still have all the backseat and everything
I said TRUNK not truck....... :)
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Explorer Cluster installed with pics <TX>TORKiT Interior Semi-Tech 10 07-10-2011 06:11 PM
Installed 2" blocks - "bump" when taking off dallas_01gt Suspension Tech 15 03-19-2009 07:21 AM
"tranny flush" and "fuel service" RangerBoy02FX4 4.0L OHV & SOHC V6 Tech 15 08-26-2006 12:32 AM
31"x11.5"x15 on a 15"x10" rim? pushdeck General Ford Ranger Discussion 6 04-19-2006 08:02 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:26 AM.