2004 ranger issues - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 10-22-2010
Thread Starter

I am: Larry Connor
Join Date: Oct 2010
Location: stafford, virginia
Vehicle: 2004 ford ranger edge
Posts: 2
Total Props: 0
2004 ranger issues

im trying to put in a new ystem. 2 ten inch infini subs and a 1000 watt blue pyramid amp. the problem im having is i turn the truck on and non of the speakers will work. however if i pullmy high/low connector out of my amp and put it back in after the truck is running everything works fine. any suggetions?
Reply With Quote
+ 0 -
Old 10-22-2010
trextegra's Avatar
I am: Kyle Couture
Join Date: Apr 2010
Location: Beacon Falls CT
Vehicle: 2000 Ford Ranger XLT
Posts: 304
Total Props: 0
get a new converter sounds like thats the problem and check for shorts
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger 2004 FUSE ISSUES fallenage31 General Technical & Electrical 5 09-17-2013 08:16 PM
boosted 2004 ranger with driveline issues 230RWHP TREMOR Drivetrain Tech 3 09-10-2012 05:30 PM
A/C issues - 2004 Ranger XLT 4.0 4WD Ceezer General Technical & Electrical 9 07-20-2011 05:47 PM
2004 Ranger Temp Issues jimdean33 General Ford Ranger Discussion 1 02-10-2010 05:13 PM
2004 Ranger Edge Fuel Pump Reset Switch Issues jOnstar 2.9L & 3.0L V6 Tech 8 01-02-2008 01:46 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:16 PM.