amp not working - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 07-20-2009
sarasota4x4's Avatar
Thread Starter

I am: jake b
Join Date: Sep 2008
Location: sarasota florida
Vehicle: 99 ranger 4x4 4.0
Posts: 404
Total Props: 0
amp not working

i bought a MTX thunder 704 amp from a buddy, and it has worked fine for a few months. The other day i noticed my subs weren't working and i checked and my remote wire had came undone. i forgot about it for a few days and finally got an allen set and tightened it back down.

i noticed the red light blinked for a few seconds, and then goes steady like it always is, and then blinks again. any ideas?

this is my amp, BTW
Car Audio Amplifiers - X Thunder 704X | MTX Audio
Reply With Quote
+ 0 -
Old 07-20-2009
bucky919's Avatar
iTrader: (1)
I am: Ramsey L
Join Date: Nov 2006
Location: Minot, ND
Vehicle: 2005 F150 SuperCrew
Posts: 1,943
Total Props: 1
Check alls your connections, power, ground, remote, fuses ect. Get you multi meter out and check to make sure the remote wire is getting power ect.
Reply With Quote
+ 0 -
Old 07-26-2009
I am: thadus roberson
Join Date: Apr 2009
Location: williamston,nc
Vehicle: 2001 FORD RANGER edge
Posts: 36
Total Props: 0
Icon6 remote wire

and if it has came off and touched the neg it could have grounded out cause the remote is a power wire and it may have burnt it up... just my 2 cents
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 07:35 PM
Ranger not charging and chime not working jfoster2505 General Technical & Electrical 3 02-14-2012 07:23 PM
A/C & Heat not working properly JBell 4.0L OHV & SOHC V6 Tech 8 05-16-2011 10:46 PM
Heater not working/not shifting right conrad General Technical & Electrical 7 01-20-2011 05:35 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:50 PM.