need help ASAP - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 02-27-2008
edge05runner's Avatar
Thread Starter

I am: steven gerrish
Join Date: Apr 2005
Location: Peoria az
Vehicle: 2005 ford ranger edge
Posts: 142
Total Props: 0
need help ASAP

Ok so ill start from the beg. I was drving to work one day and my subs cut out hit a bump and they flicked back problem figured it was a loose wire sure enough it was one of the screws were loose on the amp so i tighted everything up, all is good... Then a week or so later sub starts to cut out agian so i checked all my wires and they were all tight! So i was a lil lost there then they started to play when i turned my deck up a lil... so they wont play at low volumes anymore not a big deal. BUT now THEY DONT PLAY AT ALL!! amp light is on....wires are tight... i dunno what else it is.... and thanks in advance(sorry for the long post!)

-=2005 ranger edge=-
sonic blue 3.0 auto
Dumped Turbo Muffler
jvc kd-avx1
Alpine Amp
2 JL 12s
K&N Intake
bama chip

-=1996 F250=-
7.5 460 Big Block
many mods to come

Reply With Quote
+ 0 -
Old 02-27-2008
Hardwareman's Avatar
I am: Allen Mendez
Join Date: Feb 2008
Location: Victorville, CA
Vehicle: 1995 Ford Ranger
Posts: 166
Total Props: 0
I recently just had one of my subs do that and I thought I blew that sub for some reason. It turned out the wire inside the sub box came off. Wierd! Just a thought, or maybe sub control (if you have it) is off?

Reply With Quote
+ 0 -
Old 02-28-2008
ChrisR1S's Avatar
iTrader: (1)
I am: Chris Richardson
Join Date: Oct 2007
Location: Kenbridge, VA
Vehicle: 1994 Ford Ranger
Posts: 263
Total Props: 0
I've had the problem once or twice. Check your inline fuse and "wiggle" it while the radio and all is on, i've had the fuse block actually have a short in it somewhere. Check your ground connection too
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
E-Brake help. Please help me out. Need to get done asap. rybread5520 General Technical & Electrical 2 01-02-2009 09:41 PM
need help asap RANGERLOVER General Ford Ranger Discussion 6 09-25-2008 12:02 PM
need help asap!!! Bad water leak!!! blkranger Interior Semi-Tech 3 07-07-2005 12:53 PM
Need Help Asap BananaEdge Exterior Semi-Tech 14 04-16-2005 07:47 PM
I NEED GAUGE HELP ASAP!! (this is different than my previous gauge post) please! TippnOver Interior Semi-Tech 7 02-02-2005 11:56 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:48 PM.