No SOUND from Speakers - HELP - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 06-14-2010
Thread Starter

I am: Bryan McLeod
Join Date: Jun 2010
Location: Sesser, IL
Vehicle: 1993 Ford Ranger
Posts: 6
Total Props: 0
No SOUND from Speakers - HELP

I've got a 1993 XLT that had the premium sound installed. I went to change the radio and have NO sound whatsoever. Hooking the wires on the back of the radio to the speaker gets sound, but hooking the wires to the harness doesn't work.. We, as stupid as it sounds, cut the premium adaptor off thinking it would be easier to connect. However, no matter what combination is used, cannot get sound out of the speakers at all. I don't know what to do other than run new speaker wires from the radio to the speakers. Only problem is, I don't know how to run speaker wires through the door..

HELP!!! any suggestions..
Reply With Quote
+ 0 -
Old 06-15-2010
OneTireFire's Avatar
I am: Mike D.
Join Date: Jan 2010
Location: PBG, FL
Vehicle: 2002 Ford Ranger XLT
Posts: 206
Total Props: 0
running speaker wire is easy as hell all you have to do find the wires and where they are run through and match their path but also did you look up the wiring daigram for the radio pig tail and another thing did you get a wiring harness adapter for the ranger? and one final thing did you use butt connectors or those crappy splitter things cuz those sucks
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! No sound from speakers west22 Audio & Video Tech 11 08-12-2009 02:43 PM
speakers speakers speakers doug435 Audio & Video Tech 5 01-30-2006 12:50 PM
head unit works and amp and sub but no sound from speakers?? fletch12518 Audio & Video Tech 33 01-20-2006 04:18 PM
why would my new alpine speakers sound worse than my stock speakers? james13f Audio & Video Tech 21 04-03-2005 05:01 PM
amplified speakers, buzzing sound TippnOver Audio & Video Tech 4 11-23-2004 06:20 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:57 PM.