Subwoofer stopped working? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Audio & Video Tech

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 02-02-2010
Riddla's Avatar
Thread Starter

I am: Riddla Uknown
Join Date: Jan 2010
Location: Texas
Vehicle: 2006 F150
Posts: 140
Total Props: 0
Subwoofer stopped working?

Okay so I have a Kenwood 200 watt amp and a MTX 4500 thunder subwoofer in my Ford Probe well I was listening to it pretty loud and it worked fine until I got home and turned the car off. When I got back in the car to leave i turned it back on and i noticed the sub was not working I checked the connections and they seem good. I was messing with the stereo settings for a bit too before it stopped working

so I messed with the settings some more and nothing. Booo will check it out in more detail tomorrow when I have time.

Possibly RIP sub?
Reply With Quote
+ 0 -
Old 02-02-2010
--weezl--'s Avatar
iTrader: (1)
I am: Hunglike Ahorse
Join Date: Sep 2009
Location: Calgary AB, Canada
Vehicle: 2007 Ford Ranger FX4 L II
Posts: 3,139
Total Props: 0
check your amp's fuses, could be several of them on the amp it's self (i've never seen one with none, but seen up to 5) and the main fuse on the positive to the amp
Reply With Quote
+ 0 -
Old 02-02-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
I am: Tyler Crim
Join Date: Aug 2007
Location: Winchester, Va
Vehicle: 02 Ranger
Posts: 8,187
Total Props: 2
Check the fuses. Also check the wires inside the box connecting the sub to the amp.
Reply With Quote
+ 0 -
Old 02-02-2010
RangerJacoby99's Avatar
iTrader: (2)
I am: Ryan Jacoby
Join Date: Feb 2009
Location: Thornton,CO
Vehicle: 99 Ford Ranger Sport 4X4
Posts: 374
Total Props: 0
if you can push the on the subs speaker and get sound it means u blew the subs check that dont push to to hard though
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 01:18 PM
Want to Buy: Subwoofer enclosure for an 8 or 10 inch subwoofer - FL mulatto325 Interior, Exterior, Electrical, & Misc. 6 12-07-2011 08:48 PM
Odometer stopped working robert99ranger Interior Semi-Tech 4 09-15-2008 04:12 PM
Temperature Gauge stopped working Roger SOHC - 2.3L & 2.5L Lima Engines 1 06-01-2008 11:59 PM
Factory CD player stopped working. bleech1 Audio & Video Tech 4 04-28-2008 09:17 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:28 AM.