Leaking water pump - Ranger-Forums - The Ultimate Ford Ranger Resource


DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 3 Weeks Ago
Member
Thread Starter
 
Join Date: May 2016
Location: El Paso
Posts: 4
Leaking water pump

ok guys here the deal. I have a 2001 2.3 duratec ranger. recently I started noticing my coolant was disappearing fast. I looked for a leak and noticed the water pump are was leaking. I have replace the water pump and only used the o ring provided w/the new water pump to seal it. I have a Haynes manual and an ebay ford manual and both stated the same thing. I have rtv sealed the 8mm threaded part of the bolts but the h20 pump is still leaking. I am considering rtv-ing the whole damn thing as I am frustrated. anybody had issues w/the h20 pump before? thanks
Reply With Quote
  #2  
Old 3 Weeks Ago
ricityranger's Avatar
Member
 
Join Date: Jan 2017
Location: West Virginia
Posts: 12
Did you clean the groove well where the Oring goes? Put some copper silicone around in a very thin bead being careful that when it mounts it does not squeeze out in to the system because it can clog the Tstat and radiator passages. I usually just smear a thin layer of it on the pump then let it dry for a few hours.
Reply With Quote
  #3  
Old 3 Weeks Ago
Member
 
Join Date: Feb 2016
Location: WA
Posts: 47
When I replaced mine I cleaned the groove really well and then put a very light coat of vaseline on the ring so that it didn't bind or pinch. No leaks in the past 9 months.
Reply With Quote
  #4  
Old 3 Weeks Ago
Member
Thread Starter
 
Join Date: May 2016
Location: El Paso
Posts: 4
I have waited out the day for the rtv sealant to dry and are still having the same issue, since the pump is designed for just an O Ring to keep the water out. I believe there must be pressure in the cooling system---> maybe a bad head gasket :/ I am including a pic showing the leak. feel free to comment.

http://s1320.photobucket.com/user/ricardo_rodriguez5/media/water%20pump%20leak_zpstogscnif.jpg.html?filters[user]=133015821&filters[recent]=1&sort=1&o=0
Reply With Quote
  #5  
Old 3 Weeks Ago
Member
 
Join Date: Feb 2016
Location: WA
Posts: 47
Man, I really don't have much to offer.

That pump is pretty tight and so if there was extra pressure in the system from a bad head gasket I'm almost certain the degas bottle cap would fail first as it's rated to 16 psi.

I would have to pull that pump off again and double and triple check everything. Even put a straight edge on both the pump and block to make sure they are true. Then I'd check for any nicks or cuts in the block that may be allowing the coolant to seep past the rubber o-ring seal.

I once had an old Chevy C10 with a 350. I put a new Edelbrock intake manifold on it and the thing would leak oil at the back. Come to find out the intake was warped so I got another Edelbrock. Same damn thing! Oil leaking in the back. I returned the second one and got a Weiand intake instead. Had zero issues with it. And so maybe you got a bad pump? I used a Hitachi brand water pump on mine when I replaced it on my 2.3.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Water pump bolts leaking oil? q2quest 4.0L OHV & SOHC V6 Tech 2 11-27-2011 03:50 AM
Water pump leaking wydopnthrtl 4.0L OHV & SOHC V6 Tech 11 03-25-2009 09:03 PM
Water leaking into cab Lone Ranger 93 Interior Semi-Tech 19 07-03-2008 01:03 PM
Water Leaking into Cab rangerbert Exterior Semi-Tech 6 05-04-2008 12:44 PM
Water pump leaking? fx2offroadranger General Ford Ranger Discussion 16 02-27-2008 06:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:38 PM.