stttttttttuttering.. HELP! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow DOHC - 2.3L Duratec / Mazda L Engines

DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 08-08-2008
I am: Earl ?
Join Date: Nov 2005
Location: Elizabeth City, NC
Vehicle: 2000 Ranger XLT 4x4
Posts: 767
Total Props: 0
Is this a stuttering while maintaining a steady speed, just barely on the throttle?

Could be EGR. Pull the vaccuum line off the EGR valve and plug the line.

Drive it for a day or so like that; ignore the CEL that results.

I've seen a "going bad" DPFE cause that. Feels like trailer-hitching, as though you are pressing/releasing the gas pedal faster than humanly possible. Goes away completely at WOT (floored gas pedal).
Reply With Quote
+ 0 -
Old 08-10-2008
I am: travis strickler
Join Date: Apr 2008
Location: calhoun,mo
Vehicle: 91 ranger
Posts: 34
Total Props: 0
hey earl that was gonna be what im going to do next because just did plugs,wires, and coil pack on intake side....i figured the exhaust side wouldnt matter.....i will probably get the dpfe. i have cleaned my egr
Reply With Quote
+ 0 -
Old 08-19-2008
gr8shot's Avatar
I am: Jesse Meyers
Join Date: Jun 2008
Location: Lincoln, NE
Vehicle: 1997 B2300
Posts: 34
Total Props: 0
alright fill me in here, what is DPFE? I thought I was up to speed on all the terminology, but I guess not. Also where is the egr valve at on a 97 2.3L? How would I clean it and what should I use? I'll try plugging the vac line and see what it does.

It's basically a misfire from idle up to about 2k rpms. It seems to only miss under light throttle (or at least thats where it's most noticeable) but I can still hear it if I rev the engine and listen really hard for it. It's worst when you first take off in first gear. It'll miss right when the rpm's get their lowest, then once you start gaining rpm's and give it more gas it won't miss anymore (that I can hear). So far I've put in new plugs, new wires, new coils, and IAC valve. None of which have fixed the problem.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 11:08 AM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 12:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-15-2005 11:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:52 PM.