Transmission swap issues - Ranger-Forums - The Ultimate Ford Ranger Resource


DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 2 Days Ago
Member
Thread Starter
 
Join Date: Apr 2017
Location: Chesapeake VA
Posts: 1
Transmission swap issues

So I recently lost first gear in my transmission and I have an 03 2.3L. I rode around for about a month by just putting it into 2 and then to drive as I got going. My friend had the exact same truck but long bed and it doesn't run anymore so he let me have his old transmission and helped me to a swap. We got it all swapped out and it's all right, we made sure we lined up the torque converter properly and it still spun the way it was supposed to and the truck runs now but it is shifting very erratically (yes we added fluid) , it gets to about 4000 RPMs in first and you have to let off the gas and then give it some to make it shift into second and we haven't been able to get it into third yet. This is very troubling and I haven't got a clue where to start on this now. We're both have very basic understanding of mechanics but we are by no means mechanics. Anyone have any ideas what it could be??
Reply With Quote
  #2  
Old 2 Days Ago
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 5,981
2003 Rangers will have electronically controlled transmissions, actually 1995 and up Ranger will.

So shifting is done by the computer via solenoids IN the transmission.
Check the 10 or 14 wire connector on the transmission to make sure it is plugged in correctly and tight

If possible get the Codes read, computer will set Transmission codes if there is a problem detected.
Computer may also put transmission in to "limp mode", harsh shifting, if the CEL(check engine light) comes on


Did you service the new/old transmission, drain fluid, change filter and refill?
If it sat for awhile it will sure need that
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-25-2015 11:08 PM
Transmission issues and concerns Venom-'10Ranger Drivetrain Tech 0 02-15-2010 04:57 PM
Transmission issues and concerns Venom-'10Ranger General Technical & Electrical 0 02-15-2010 04:54 PM
Transmission issues robmac Drivetrain Tech 2 12-30-2007 04:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:59 AM.