4WD low barely functioning - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Drivetrain Tech

Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 10-23-2007
Thread Starter

I am: J M
Join Date: Mar 2007
Location: Kenai, AK
Vehicle: 2000 ranger
Posts: 54
Total Props: 0
4WD low barely functioning

not sure what the problem is. last night i got it to work, but today it didnt. im doing everything right (stopped, in neutral, clutch in), but when its in 4WH and i switch it to 4WL, i hear one click, but the light doesnt come on.
Reply With Quote
+ 0 -
Old 10-23-2007
btatum's Avatar
I am: Billy Tatum
Join Date: Jul 2007
Location: Palestine, TX
Vehicle: 1998 Ford Ranger
Posts: 19
Total Props: 0
Hold the brake pedal, don't mash it, just enough to make the switch activate.. I used to have the same prob until I learned that, and now it works every time without hesitation. (In addition to holding the clutch and it being in neutral going less than 2 Mph.)

Last edited by btatum; 10-23-2007 at 04:42 PM.
Reply With Quote
+ 0 -
Old 10-24-2007
Downey's Avatar
RF Veteran
iTrader: (1)
I am: Cameron Downey
Join Date: Oct 2007
Location: Muncy, PA
Vehicle: 1994 Ford Ranger
Posts: 8,470
Total Props: 0
i have the same problem only mine doesnt come do anything when i hit the button anyone can help me it would be nice to have
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
4WD High and 4WD Low lights flash while driving in 2WD bleech1 General Technical & Electrical 8 09-08-2016 11:30 AM
For Sale: Front Bilsteins 4wd 99 barely broken in - Scotch Plains njdriver04 Suspension, Tires, & Wheels 4 05-14-2012 01:56 PM
LOW LOW LOW RPMS JRacer 4.0L OHV & SOHC V6 Tech 23 05-06-2009 11:25 PM
4WD and 4WD low lights flash periodically HarryTasker Drivetrain Tech 10 01-19-2007 06:16 PM
OHC Map light no functioning 05ranger General Technical & Electrical 28 10-22-2006 02:18 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:41 PM.