94 3.0 A4LD slipping - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Drivetrain Tech

Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 07-08-2008
Thread Starter

I am: Shawn Pierson
Join Date: Jul 2008
Location: Port Orchard, WA
Vehicle: 1994 Ford Ranger
Posts: 2
Total Props: 0
94 3.0 A4LD slipping

Couple month's ago trans wouldn't go, engine would rev and eventually trans would grab and go. Found low trans fluid level. Filled it and truck ran fine. Then I noticed a puff of white/gray smoke from exhaust occasionally. A week later trans slipping again. No leaks under truck and trans fluid level was low again. Changed trans filter and fluid that was in the pan during removal. Filled fluid again and it ran fine. Another week and slipping again along with the white/gray smoke from exhaust. Realized fluid was leaking from trans to the engine intake through vacuum modulator. Replaced it with a Fram modulator. No more fluid drop or smoke but now trans slips/hesitates between gears. Pulled the Fram and installed the Ford OEM Motorcraft modulator and slipping was less but is still there between gears.
Any ideas of what is going on????
I hooked vacuum gage to intake and I've got approx. 16" wg during idle.
Another question. My Chilton book says to remove the modulator and the modulator control rod. Install control rod and then modulator. Is this control rod attached to the modulator? I saw a rod/spool behind the modulator but didn't dig to get it out just so I could put it back in. It wasn't mechanically attached.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
EDIT: Slipping Clutch (I'm an Idiot) edgecellent02 Drivetrain Tech 4 02-05-2013 08:24 PM
Noise / Slipping in Reverse? dwildberger Drivetrain Tech 2 11-02-2007 06:53 PM
slipping chris_w_2008 Drivetrain Tech 2 10-21-2007 10:44 PM
things are bad...slipping to no go in my auto mfp4073 Drivetrain Tech 8 09-16-2007 09:55 AM
Is This a Slipping Tranmission? this_is_nascar Drivetrain Tech 6 01-29-2007 08:11 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:33 PM.