Not sure if this is my u-joint - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Drivetrain Tech

Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 03-13-2008
01 ranger's Avatar
Thread Starter

I am: Jon Parker
Join Date: May 2007
Location: Tampa, FL.
Vehicle: 2001 ford ranger
Posts: 140
Total Props: 1
Not sure if this is my u-joint

After doing some trail riding this past weekend, my truck started to make a squeaking/chirping noise. Its coming from the rear around my driveshaft. I have searched and found threads which led me to believe that this is my u-joint. Before i start messing with it i thought i would run this by you guys to see what you think it is.

When im in drive, it starts to chirp/squeak and gets faster as the truck goes faster. If i am at a crawl, it almost sounds like its a rubbing noise. It is a hollow sound.

Now what im really concerned about is when i put it in reverse, it makes a cracking noise like its under pressure then suddenly releases. Then it continues to make a loud ticking noise. So... do yall think its the u-joint or somthing else. I appreciate any help.

01 RANGER XLT 4X4 3.0
3" BL, T-BAR CRANK, 15X10 SOFT 8'S AND 33'S
2 12" SUBS 740 WATT AMP
Reply With Quote
+ 0 -
Old 03-13-2008
My05edge's Avatar
I am: The Maytag Man! Rice
Join Date: Dec 2006
Location: Midland, TX
Vehicle: 2002 Ford Ranger FX4
Posts: 1,351
Total Props: 0
i got the same problem, hope someone knows what the problem is
Reply With Quote
+ 0 -
Old 03-13-2008
ranger_1999's Avatar
iTrader: (3)
I am: Dustin McCann
Join Date: Jan 2008
Location: spindale, NC
Vehicle: 98 Jeep ZJ
Posts: 1,444
Total Props: 0

DEFINATLY the u-joint...On my yota, i had a bad u-joint..I thought it was the tires and stuff...Well i figured out thats what it was...Crawl under your rig and turn your driveshaft back and forth firmly..If it moves or feels like its slipping its your u-joint and maybe your whole houseing...I had let myn go so long the u-joint bored a hole twice the size of the joint into the housing...had to replace everything....Yeah mine chirped like your describing too.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not sure if it's a problem or not jtfoxman Drivetrain Tech 3 09-04-2008 01:43 PM
Not sure if this is normal or not Srkasner Drivetrain Tech 9 08-06-2007 07:49 AM
Running a Johnny Joint / Superflex Joint on the Track Bar zabeard Suspension Tech 20 04-11-2007 08:36 AM
Not Sure What's Wrong eXtremePC 2.9L & 3.0L V6 Tech 19 11-12-2004 11:08 AM
Not sure if this is the right forum... problem with forum Wowak Ranger-Forums Office 6 08-04-2004 01:13 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:59 PM.