weird noise after disengaging 4wd? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Drivetrain Tech

Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 01-19-2008
Naturally Aspirated's Avatar
Thread Starter

I am: Jonathan .
Join Date: Dec 2006
Location: Roy, Utah
Vehicle: 2001 Edge
Drive Type: 4x4
Engine: 4.0
Posts: 476
Total Props: 0
weird noise after disengaging 4wd?

i should've asked this long ago, but i forgot about it. so anyways when i disengage 4wd, i hear a high-pitched whine. it's not super loud or anything, but i notice it. i can only think of one other time it did this, which was a long time ago. i don't use 4wd that much either.

anyone know what it could be?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
4wd disengaging under load rangerstepside Drivetrain Tech 3 06-04-2012 04:52 PM
weird noise after i start sgalka91 4.0L OHV & SOHC V6 Tech 9 11-09-2009 06:37 PM
weird noise after BL. cchsbuzz19 General Ford Ranger Discussion 9 09-22-2009 03:32 PM
trouble disengaging 4wd zabeard Drivetrain Tech 44 12-14-2006 08:01 PM
Clutch is soft and not disengaging jorlee Drivetrain Tech 36 12-30-2005 03:06 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:41 PM.