04 2.3 P0316 (crank sensor condition) - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 07-09-2012
Thread Starter

I am: kevin totts
Join Date: Jul 2012
Location: pasco florida
Vehicle: 2004 Ford Ranger 2.3 auto
Posts: 37
Total Props: 0
04 2.3 P0316 (crank sensor condition)

I had this condidtion about a week ago as well as P0304 (cyl 4 misfire) and was told to clear the code and unplug/clean the sensor connector and check plugs, wire, ect. I cleaned connector and cleaned inside of wire boots and all was good. I cleaned intake/throttle body and sensors and got idiot light. Figured it was emissions code, so i took neg off again and let it sit for about 30min. Started and ran in driveway for a while with no check engine, then drove 5 min to get it scanned and got a P0606 internal memory error. I cleaned ECM connector. Even peeled back harness loom and visually checked for breaks or damage with nothing found. Hooked everything up and truck ran good with no check engine light. So never the less i drove to/for work with it (mobile gen tech). I get to work and my sub blows... ok, thats fine. gona go bigger anyway Then when i start the truck to leave i get idiot light. got it scanned P0316 and P0304 again. bought/changed plugs on spot. No difference, but drove anyway because i had to do my service calls. Bought/installed a set of Bosh wires as soon as i got off. No difference. it only has a slight misfire that you can bearly notice. I only hear/feel it because there is no more sub
truck was sunk and had bad lifter tap that i mannaged to get to go away after it warms up. is it possible that i bent a valve and am getting blow by or inadequate pressure in the head causing a misfire? Im going to change sensor ASAP of course, i just have a feeling that the head has something wrong with it internally.
I would really like some opinions...
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 2.3 P0316 (crank sensor condition) tater's ranger DOHC - 2.3L Duratec / Mazda L Engines 13 07-26-2012 06:28 PM
2004 2.3 crank sensor condition code tater's ranger General Technical & Electrical 0 07-05-2012 05:11 PM
Code P0316 d1zturbe3d 2.9L & 3.0L V6 Tech 8 09-20-2010 10:46 AM
Want to Buy: Good Condition Mass Airflow Sensor fx4wannabe Engine & Drivetrain 8 03-21-2010 04:00 PM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 10:35 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:00 AM.