94 Ranger unexspected behavior - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 06-10-2013
Thread Starter

I am: Jeff Stout
Join Date: Jun 2013
Location: Virgin, Utah
Vehicle: 09/1994 Ford Ranger
Posts: 2
Total Props: 0
94 Ranger unexspected behavior

My 94 ranger 2.3 manual 2wd went from running good to all of a sudden bad! Pretty much since the weather has been gettin hot its been acting up.. I tested the k-ohms on the coil packs and they are good, new wires, good plugs. I've recently put a new fuel pump in it not even a year ago so I'm pretty sure that's all good. So then I did a compression test on all cylinders. cylinders 4
, 3 and 2 all had from 115 to 125 p.s.i. But cylinder 1 only had 60 :/ 1 of 2 questions. Would a valve job fit the problem? & could this possibly be caused by a clogged cat.?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
eird 8.8 axle behavior ianyboy Drivetrain Tech 3 11-21-2014 04:11 PM
OHC Temperature Probe... Odd behavior heaton84 General Technical & Electrical 29 12-19-2010 11:10 AM
Strange Engine Behavior... RangerMarsh General Ford Ranger Discussion 7 06-23-2010 07:29 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:39 PM.