Ac problem. - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-26-2016
Thread Starter

I am: Giuseppe Bottaro
Join Date: May 2016
Location: Fort Pierce, Fl
Vehicle: 1999 Ford Ranger
Drive Type: 2x4
Engine: 3.0
Posts: 1
Total Props: 0
Ac problem.

I have a 99 ranger an the a.c. fan speed switch isn't working besides the last speed. The first 3 speed dont work. Any idea what it is. A.c. blows ice cold etc. Started lastnight the issues.
Reply With Quote
+ 0 -
Old 05-26-2016
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,761
Total Props: 88
Welcome to the forum

Most common reason for only high speed on blower motor is failed Resistor block on the motor housing, or corroded connectors on the blocks plug in.
Resistor block costs $10-$25 depending on year

Video here:

Other place it can fail, but less common, on the back of the fan switch in the cab panel, remove panel and have a look for melted wires on the switch.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 05:58 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:02 PM.