Oil light again!!! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-22-2010
Nckdula's Avatar
Thread Starter

I am: Nick Dula
Join Date: Sep 2010
Location: West Jordan UT
Vehicle: 1988 Ford ranger XLT
Posts: 178
Total Props: 0
Oil light again!!!

I already went over this the first time but.......
Today well driving, i noticed my oil light come on a couple times, but it's not always on, usually when i accelerate it will brighten up, and it's not a steady red, instead it kind of flickers, and then sometimes it's not even on.
So what are the best ways to troubleshoot the issue? starting with the censors or what?
Reply With Quote
+ 0 -
Old 12-23-2010
Bird76Mojo's Avatar
iTrader: (2)
I am: B B
Join Date: Dec 2009
Location: Central, IL.
Vehicle: 2001 Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 1,257
Total Props: 0
The sensor on the side of the oil pan, where the wire plugs onto it, can get corroded and/or dirty. Take the connector off and clean it out. If it's loose then crimp down on it a tiny bit and push it back onto the sensor. Also check the wire for cracks or breaks. Mine had the same problem.

Although, at 290,000 miles it's probably a safe bet that your oil pump is getting weak.

GB :)
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Light ( Low Oil light ) ?? justinkeoughan 4.0L OHV & SOHC V6 Tech 9 03-25-2010 05:47 PM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 10:25 AM
on again off again zorki1 DOHC - 2.3L Duratec / Mazda L Engines 6 02-02-2009 02:02 PM
Damage Report: Shock, Hubs, Skid, Light, Again... rngprerunner Snapshots 24 01-08-2009 11:21 AM
Airbag Cluster Light flashing yet again. 01xltranger4x4 General Technical & Electrical 8 05-08-2007 04:15 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 02:25 PM.