Weird ac issue - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-15-2013
Thread Starter

I am: Ivan Castillo
Join Date: Mar 2011
Location: Edinburg
Vehicle: 1996 Ranger Standard Cab
Posts: 28
Total Props: 0
Weird ac issue

Ok so yesterday on the way to work ac was working great as usual. Halfway there though the compressor shut off. Later that day I jumped the low level pressure sensor to diagnose it. The ac clicked on and worked great, i picked up a new one and swapped them out and the ac worked great again. Just to be sure I threw on the gauges and the levels seemed fine. Well again this morning halfway to my way to work it shut off. The compressor can be jumped via shorting the switch harness and it works great. Is it likely I got a bad switch or is there something else I can check? There is no evidence of leaks and the gauges read fine. Any thoughts?
Reply With Quote
+ 0 -
Old 05-17-2013
web's Avatar
web web is offline
I am: Jeff Webber
Join Date: Oct 2011
Location: Columbia, MD
Vehicle: 2004 Ranger XLT
Drive Type: 4x4
Engine: 4.0
Posts: 210
Total Props: 1
Check your refridgerant levels again when cold. When cold, the A/C will kick on due to ambient temperatures not causing the refridgerant to disperse. Once warm, the low pressure switch will shut the compressor off to save it, as the lubrication is not enough inside the system.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird A/C elec. issue Goats General Technical & Electrical 9 03-13-2010 08:19 AM
Weird drum brake issue Blades24 General Technical & Electrical 25 03-11-2010 03:14 PM
Weird electrical issue uhittheuglytree General Technical & Electrical 2 02-19-2010 02:07 PM
Weird Air Conditioning Issue...Help Prerunner-Ranger General Technical & Electrical 21 08-16-2008 09:04 AM
Weird overheating issue RANGERMAN66 4.0L OHV & SOHC V6 Tech 5 12-08-2007 05:34 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 02:00 AM.