The "What did you do to your Ranger today" thread - Page 114 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #2826  
Old 09-28-2011
Ranger_Chris's Avatar
Member
 
I am: chris smyth
Join Date: Mar 2008
Location: brampton, ontario
Vehicle: 2010 Ranger SPORT
Posts: 26
Total Props: 0
Hurst Shifter

This is kind of cheating 'cause I didn't do it today - I did it in June; but I installed a hurst shifter in my ranger.

I ended up ordering it because I attempted to change the shift **** on my 2010 sport, and after a lot of grunt work and making a huge mess of my shifter, I realized I couldn't attach anything to the top without some serious customization.

All-in-all, I ended up buying a Hurst Shifter - and now am very freakin happy that I screwed the thing up to begin with. I did the work myself (using a tutorial on here.. I just searched for 15 mins and couldn't find it again - sorry to whomever it was - I owe you! The step-by-step tutorial was awesome!). The whole project altogether took me about 4 hrs (in twilight where i could barely see lol).

Anyways, in hindsight I should have taken some pictures before and during... but here are some pics after the installation - did I mention this is the best decision I've ever made?

The "What did you do to your Ranger today" thread-img_0978_downscaled.jpg
The "What did you do to your Ranger today" thread-img_0979_downscaled.jpg
Attached Thumbnails
The "What did you do to your Ranger today" thread-img_0977_50.jpg  

Last edited by Ranger_Chris; 09-28-2011 at 08:46 PM. Reason: Resized the pictures!
Reply With Quote
+ 0 -
  #2827  
Old 09-29-2011
Scrambler82's Avatar
Old Guy Userů ltr

iTrader: (12)
 
I am: Grev B
Join Date: Jul 2009
Location: SoCal
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 6,627
Total Props: 10
Did you add any insulation under the cup holder/shift bezel ?
You will need to if not, to get rid of the gear noise/vibration.
There is a "How-To" on the subject but just use some foam. I used some sound proof mat on the floor and arund the shifter but it is needed.

Luck



Quote:
Originally Posted by Ranger_Chris View Post
This is kind of cheating 'cause I didn't do it today - I did it in June; but I installed a hurst shifter in my ranger.

I ended up ordering it because I attempted to change the shift **** on my 2010 sport, and after a lot of grunt work and making a huge mess of my shifter, I realized I couldn't attach anything to the top without some serious customization.

All-in-all, I ended up buying a Hurst Shifter - and now am very freakin happy that I screwed the thing up to begin with. I did the work myself (using a tutorial on here.. I just searched for 15 mins and couldn't find it again - sorry to whomever it was - I owe you! The step-by-step tutorial was awesome!). The whole project altogether took me about 4 hrs (in twilight where i could barely see lol).

Anyways, in hindsight I should have taken some pictures before and during... but here are some pics after the installation - did I mention this is the best decision I've ever made?

Attachment 24767
Attachment 24768
Reply With Quote
+ 0 -
  #2828  
Old 09-30-2011
Orlando1701's Avatar
Member
 
I am: Troy Stull
Join Date: Apr 2009
Location: Orlando, Florida
Vehicle: 2004 Ford Ranger
Posts: 34
Total Props: 1



This happened. Not bad for a 04', 100K and a new set of ball joints is the only 'major' work I've had to do.
Attached Thumbnails
The "What did you do to your Ranger today" thread-100kranger4.jpg   The "What did you do to your Ranger today" thread-100kranger9.jpg  
Reply With Quote
+ 0 -
  #2829  
Old 10-01-2011
Member
 
I am: RJ G
Join Date: May 2009
Location: Hazleton, PA
Vehicle: 2002 Ford Ranger XLT FX4
Posts: 216
Total Props: -2
OMG where do I start?

I've made some mad progress on my clutch "project".

Got all new parts: Front prop shaft, sandblasted rear driveshaft, new tranny mount, new crossmember, new U-joints all around, Centerforce clutch, new clutch slave cylinder... and I even had the flywheel machined. Also got new bolts for everything.

Clutch slave cylinder and flywheel are on but the new clutch doesn't seem to line up right. Compared it to the original clutch and it's an exact match (except not worn at all).

Going to pull the flywheel and see what I'm doing wrong.

After that, still gotta get that stray stud out of the transfer case flange.

Lastly, I'm going to POR-15 EVERYTHING before putting it all back together.
Reply With Quote
+ 0 -
  #2830  
Old 10-01-2011
Taylor's Avatar
Ive been dubbed....an old volk
iTrader: (18)
 
I am: not ashamed of the gospel
Join Date: Mar 2010
Location: Nashville, NC
Vehicle: 2004
Posts: 7,110
Total Props: 26
Rolled over 80k the other day (not too bad for an 04 either) Changed the oil the other day.

Washed it. Might change rear diff fluid today (finally)
Reply With Quote
+ 0 -
  #2831  
Old 10-01-2011
djfllmn's Avatar
Moderator
 
I am: DJ Fillman
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Total Props: -4
washed it
Reply With Quote
+ 0 -
  #2832  
Old 10-01-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
I am: Dave k
Join Date: Jul 2010
Location: RI
Vehicle: 2003 Toyota Taco TRD
Posts: 5,030
Total Props: -109
Wirelessly posted

Picked her up at the trans shop
Reply With Quote
+ 0 -
  #2833  
Old 10-01-2011
Member
 
I am: James D
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Vehicle: 2012 F-150 Lariat
Posts: 563
Total Props: 1
Was going to town for a balance and rotate, until I noticed the wife took both sets of keys... Guess I won't do a damn thing but watch football now... damn the luck...
Reply With Quote
+ 0 -
  #2834  
Old 10-02-2011
CBrooks89's Avatar
Member
 
I am: C Brooks
Join Date: Feb 2011
Location: Burton, MI
Vehicle: 1999 Ford Ranger
Posts: 87
Total Props: 0
hauled all my **** from my ex gfs Since she decided to brake up w me
Reply With Quote
+ 0 -
  #2835  
Old 10-02-2011
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
I am: Adam L.
Join Date: Mar 2009
Location: Clinton, Ontario
Vehicle: 2007
Posts: 8,181
Total Props: 19
Dropped mine off at my dad's... I'll see it in a week or so!
Reply With Quote
+ 0 -
  #2836  
Old 10-02-2011
Lazler's Avatar
Senior Member
iTrader: (18)
 
I am: Christopher Laskey
Join Date: Dec 2008
Location: Brantford, Ontario
Vehicle: 2005 Ranger Edge 4x2
Posts: 5,526
Total Props: 3
Quote:
Originally Posted by Orlando1701 View Post
This happened. Not bad for a 04', 100K and a new set of ball joints is the only 'major' work I've had to do.
Quote:
Originally Posted by Taylor View Post
Rolled over 80k the other day (not too bad for an 04 either) Changed the oil the other day.

Washed it. Might change rear diff fluid today (finally)
I have an '05 with only 36 290 Miles (58 400km)
Reply With Quote
+ 0 -
  #2837  
Old 10-02-2011
Chris98's Avatar
Member
iTrader: (3)
 
I am: Chris Murray
Join Date: Feb 2010
Location: Thornton, CO
Vehicle: 1998 Mazda B4000
Drive Type: 4x4
Engine: 4.0
Posts: 705
Total Props: 1
Made up my mind on it today that I'm gonna trade it in in Feb for a 06-08 Ranger.
Reply With Quote
+ 0 -
  #2838  
Old 10-02-2011
Member
 
I am: RJ G
Join Date: May 2009
Location: Hazleton, PA
Vehicle: 2002 Ford Ranger XLT FX4
Posts: 216
Total Props: -2
Got the new clutch in (FINALLY ), tranny lined up and bolted back in, and put in a new (junkyard) crossmember. The old one was rusted through and broken in several places.

Now I have to POR-15 both driveshafts and somehow put the starter back in.

I've also managed to remove the rear flange on the transfer case and actually got the broken stud out

Gonna replace the seal back there if I ever find a new one to put in....
Reply With Quote
+ 0 -
  #2839  
Old 10-02-2011
Scrambler82's Avatar
Old Guy Userů ltr

iTrader: (12)
 
I am: Grev B
Join Date: Jul 2009
Location: SoCal
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 6,627
Total Props: 10
I finally ordered the new speakers and amp.
Now I can install the Nav Unit.
Reply With Quote
+ 0 -
  #2840  
Old 10-03-2011
Member
 
I am: harold t
Join Date: Oct 2010
Location: Pennsville
Vehicle: 1988
Posts: 11
Total Props: 0
1994 reg cab

Over the last two weeks I replaced the rear leaf spring mounts,shackles,bushings,rear shocks,brake lines,wheel cylinders,brake shoes,gas tank filler tube,right cab mount and muffler
I know that's more than a day
Reply With Quote
+ 0 -
  #2841  
Old 10-04-2011
Member
 
I am: Chandler Eash
Join Date: Mar 2011
Location: Mount vernon, Ohio
Vehicle: 1998, ford , ranger
Posts: 21
Total Props: 0
finished my flowmaster 40 ehaust and took my cats off let me know whatcha think!

Reply With Quote
+ 0 -
  #2842  
Old 10-04-2011
Member
 
I am: Bob Reese
Join Date: Sep 2011
Location: Newtown, Pa
Vehicle: 97 Ford Ranger times 2
Posts: 2
Total Props: 0
Drove to my DIVORCE ATTORNEY!
Reply With Quote
+ 0 -
  #2843  
Old 10-04-2011
Member
 
I am: James D
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Vehicle: 2012 F-150 Lariat
Posts: 563
Total Props: 1
Attempted to pull my Blazer from its final resting place, couldn't do it. So I hooked it to the trailer and used the jeep to do it. No problem. Get it in place and move the jeep to use the winch to pull it onto the trailer, get it on there and set in place lock it down, back the truck onto the driveway and notice its definatly time for springs. So much for the $ I got for selling the blazer. First time I'll be down to 3 vehicles in 12 years.
Reply With Quote
+ 0 -
  #2844  
Old 10-04-2011
04x4ranger's Avatar
Member
 
I am: aj s
Join Date: Sep 2011
Location: beverly ma
Vehicle: 04 Ford Ranger
Posts: 72
Total Props: 0
filled her tank!
Reply With Quote
+ 0 -
  #2845  
Old 10-05-2011
Chris98's Avatar
Member
iTrader: (3)
 
I am: Chris Murray
Join Date: Feb 2010
Location: Thornton, CO
Vehicle: 1998 Mazda B4000
Drive Type: 4x4
Engine: 4.0
Posts: 705
Total Props: 1
Finally fixed all the issues I've been having with it. As some of you know I've been running lean on bank 1 and 2 now for over a year. Pulled like 20 codes at the time. All the sensors that had to do with the emissions were out, so one by one I replaced them, MAF, IAC, and all the Oxygen Sensors. Still was running lean in both banks, so I replaced the intake gasket as it had a leak and a vacuum line. It was still running lean. Checked EGR, working perfect, I was completely lost of where to look next. Mind you during this time I had replaced the spark plugs 3 times as they kept fouling out, spark plug wires once.

So yesterday I had some extra cash and the coil pack was original with 218xxx miles on it. So I replaced that as well with a new set of spark plugs. Fixed all my rough idle and misfire issues, truck isn't running lean no more. Still confused on that, cause the truck should have ran rich if it wasn't getting enough spark, maybe the computer over compensated and made it run lean I don't know. All I care is that it is no longer running lean.


2012 Chevy Silverado 1500 Crew Cab
1998 Mazda B-FORD-K: 4.0L | Auto | 4x4 | 244,000 miles
3" Body Lift | 33x12.50R15 Goodyear Duratracs | 31 Spline 8.8 Limited Slip | 4.10's
Super Lift | Coil Overs | Explorer Springs | 2" Shackle
FX4 Lvl 2 Seats | Explorer OHC | Full Length Center Console
C4x4 Front Bumper | 2006 Ranger Conversion | 15% Tint Over Factory
Recon 10.5K Winch | Headache Rack | Cobra CB | TG Rock Sliders | 200 Amp Alt
Parted Out


Reply With Quote
+ 0 -
  #2846  
Old 10-05-2011
natemaybee's Avatar
Member
 
I am: Nathan maybee
Join Date: Oct 2011
Location: Henderson
Vehicle: 1997 Ford Ranger xlt
Posts: 1
Total Props: 0
Cabin Roof 97 xlt

ten bucks for fabric and ten for spray adhesive.


Uploaded with ImageShack.us



Uploaded with ImageShack.us
Attached Thumbnails
The "What did you do to your Ranger today" thread-dscn2164q.jpg  

Last edited by natemaybee; 10-05-2011 at 02:13 AM. Reason: images
Reply With Quote
+ 0 -
  #2847  
Old 10-05-2011
98liftedranger's Avatar
RF Veteran
iTrader: (5)
 
I am: Adam
Join Date: Aug 2008
Location: California
Vehicle: 2012
Posts: 12,538
Total Props: 73
I moved a 55" big screen tv in my f150 in the rain today. lol And now my truck is dirty after washing it on Saturday morning. Reason why I don't wash it.
Reply With Quote
+ 0 -
  #2848  
Old 10-05-2011
98_ranger's Avatar
Member
 
I am: Josh Frazier
Join Date: Sep 2011
Location: Columbia,SC
Vehicle: 1998 Ford Ranger xlt
Drive Type: 2wd
Engine: 2.5
Posts: 180
Total Props: 0
I am currently looking at it everyday sit in the drive way because it is stumping me. I don't know why it wont start....
Reply With Quote
+ 0 -
  #2849  
Old 10-05-2011
kanuck15's Avatar
Member
 
I am: Joe
Join Date: Mar 2011
Location: Pennsylvania
Vehicle: 1998 Ranger
Drive Type: 4x4
Engine: 5.0
Posts: 844
Total Props: 2
Is it turning over? or the starter wont even kick?
Reply With Quote
+ 0 -
  #2850  
Old 10-05-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
I am: Alex P
Join Date: Dec 2010
Location: Flat Rock, Mi
Vehicle: 1999 XLT off road.
Posts: 6,313
Total Props: 49
Quote:
Originally Posted by 98_ranger View Post
I am currently looking at it everyday sit in the drive way because it is stumping me. I don't know why it wont start....
Post a new thread about it and give us some details man. theres a bunch of Mechanics here and i'm sure we can put heads together.
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
The "What do you hate about your Ranger today" thread winks General Ford Ranger Discussion 172 09-12-2016 11:07 AM
The "What do you hate today about your Ranger" thread. dcrymes99ranger General Ford Ranger Discussion 32 10-08-2010 05:01 PM
"what did you do today....should be a category in the forums list dixie_boysles Ranger-Forums Office 6 05-26-2009 11:34 PM
For people with the "shorty" console.....where did you place you switches in/on it? lifted97ranger General Technical & Electrical 13 12-30-2007 11:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 08:11 AM.