07 Ranger Wipers Not Working - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 11-25-2012
Thread Starter

I am: Bill Taylor
Join Date: Nov 2012
Location: Ottawa, Ontario, Canada
Vehicle: 2007 Ford Ranger Sport
Posts: 1
Total Props: 0
07 Ranger Wipers Not Working

Hi all, I need your help. I have a 2007 Ranger sport 3.0L 2wd 5speed. I have been encountering this problem for a long time now. My wipers and my washer abilitys are not working. I have replaced all the the fuses, the wiper motor and the multifucion switch. A Ford tech told my it is the Sub Junction box. Where in the hell is the Sub Junction box on these trucks. And is a Sub Junction box from a older model compatible? All your help would be appretiated.
Reply With Quote
+ 0 -
Old 11-26-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
I believe the tech was making reference to the SMART JUNCTION BOX aka SJB. It should be located behind the passengers side kick panel. It does contain what Ford references as the Low Current Board, which presumably has the integrated control circuits for the wiper functions.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 11:45 AM
Dome lights, wipers not working Jrob1965 General Technical & Electrical 6 12-27-2013 01:46 AM
Wipers and Washer Fluid Squirter Stopped working 95whitelightning General Technical & Electrical 6 10-30-2010 08:20 PM
windshield wipers not working and i b going nuts redhawk15 General Technical & Electrical 1 10-02-2010 03:25 PM
wipers stopped working - relay or motor? 2002 4.0 Noone General Technical & Electrical 4 09-04-2010 02:55 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:36 PM.