1990 XLT 4WD problem - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-06-2007
Thread Starter

I am: Chris Kemp
Join Date: Dec 2007
Location: Brandon, MB Canada
Vehicle: 1990 Ford Ranger XLT
Posts: 4
Total Props: 0
1990 XLT 4WD problem

In addition to the new problem I posted in a different thread I have also been having this problem with my 4WD...
Manual hubs are locked. I push the button on the dash for 4wd and nothing happens. No lights, no 4WD, nothing. I do hear a clicking sound from the module behind the drivers seat but that's it. I've pushed the reset button but the only thing that does is light up a red light on the module until I push the button on the dash again. Everything worked fine last time I needed it. Now, not so much. Any suggestions?
Reply With Quote
+ 0 -
Old 12-06-2007
Level III Supporter
iTrader: (2)
I am: z s
Join Date: Jun 2004
Location: usa
Posts: 24,936
Total Props: 4
take the modual apart and clean it...
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 Ranger 4.0 4wd/Auto fayjim2 General Ford Ranger Discussion 3 05-14-2015 11:14 AM
1990 Ranger 4WD front shifting problem doug Rooney Drivetrain Tech 0 12-02-2013 02:57 AM
1990 Supercab 4wd Owner new here bahndrvr Member Introductions 4 07-27-2010 06:32 AM
1990 2.3l ignition problem scoutsize SOHC - 2.3L & 2.5L Lima Engines 7 07-05-2009 01:28 PM
1990 Ford Ranger Tranny problem? jdckpdl Drivetrain Tech 0 06-12-2009 09:49 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:05 AM.