2001 Ford Ranger XLT having problems starting - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 03-01-2015
Thread Starter

I am: Cody
Join Date: Mar 2015
Location: Saint Louis, MO
Vehicle: 2001 Ford Ranger XLT
Drive Type: 4x4
Engine: 4.0
Posts: 1
Total Props: 0
2001 Ford Ranger XLT having problems starting

Two days ago I had some issues getting my 2001 Ford Ranger XLT 4.0 SOHC (200K miles) to start. It would turn over fine, but I noticed a few things. My check gage light was on indicating that I need fuel, but I had over 3/4 of a tank. I figured it was a fuel or fuel pump issue because it has not been changed and my mileage is climbing. It has been very cold for the last week or so as well so I didn't know if water had gotten into something and frozen.

I would turn the key and would not hear the pump run. Then I pulled out my manual and found the fuse for the fuel pump and checked it. The fuse was still good and I got back into my truck to see if anything changed. Now when I turn the key the pump would run. I turned it about 4 or 5 times and it ran every time.

After about 4 or 5 times of driving and starting my truck normally it happened again. So after finding the same issues as the first time, I removed the fuel pump fuse and put it back to find that the fuel pump would begin running again.

Anyone have any ideas on what this could be? I don't have a garage and there is about 7 inches of snow on the ground so I haven't been too inclined to begin working on it.

I suppose the my next step is to have someone turn the key while I touch and listen to the fuel pump relay to make sure it is operating correctly when my fuel pump isn't running.
Reply With Quote
+ 0 -
Old 03-01-2015
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,742
Total Props: 88
Not sure on the 2001 but there should be 3 relays in the engine fuse box that are the same part number.
Fuel Pump(FP) relay and WOT(wide open throttle) relay should be the same, swap them around, that will tell you if FP relay is the issue.
WOT relay only works at WOT, turns off A/C compressor and tells computer to ignore O2 sensors and fuel economy, "driver wants to GO FAST!", lol.

Look at the FP fuse contacts could just be some corrosion in there causing intermittent connection

Computer(PCM) monitors FP power, PCM turns on the FP Relay and then reads if relay closes and FP wire has 12volts on it.
So that could activate the check gauge light, if PCM didn't see the 12v on the FP wire, just guessing that but it would make sense from the wiring diagrams I have seen.

PCM only runs fuel pump for 2 seconds when key is turned on, fuel pump doesn't start again until engine RPMs are above 500, or if key is cycled off then on again, reads like you already know this, but just wanted that to be clear on that part.

The PATS anti-theft system also controls the fuel system, but you should get a flashing "theft" light if that was the issue.

Last edited by RonD; 03-01-2015 at 03:43 PM.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help having trouble starting pdanowski SOHC - 2.3L & 2.5L Lima Engines 3 01-03-2014 06:57 AM
Having trouble starting Auto 2.9L & 3.0L V6 Tech 2 01-24-2010 12:39 PM
Having trouble starting my truck redlinerick86 2.3L & 2.5L I4 Tech 9 03-18-2008 02:41 PM
Having trouble starting my truck volcompro11 2.9L & 3.0L V6 Tech 3 10-21-2007 01:25 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:06 PM.