Anyone had this problem, or advice on it: - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-28-2013
Thread Starter

I am: Jim Mcdaniels
Join Date: Aug 2013
Location: Colorado Springs, Colorad
Vehicle: 1993 Ford Ranger 4.0L
Posts: 5
Total Props: 0
Anyone had this problem, or advice on it:

Anyone had this problem, or advice on it:

My 93 4.0L ranger now has 170,000 miles on it.

About 8 years ago, the original R12 ac system would no longer hold a freon charge more than about a 1 year so I retrofitted to r134a freon with r134a oil with stop leak.

System has worked fine all these years but now a terrible freon/oil sickly sweet smell is leaking out of the ac dash vents causing headaches in people with the vents blowing in their faces whenever the ac is turned on and continuing shortly after being turned off.

Guess it's the evaporator or some o ring seals leaking.

Not sure how hard it is to determine the point of leak and repair or even access the evaporator.

Any advice or suggestions besides, not to use the ac till repaired, would be great.

Reply With Quote
+ 0 -
Old 08-29-2013
marc83's Avatar
I am: Marc Krier
Join Date: Sep 2009
Location: Tyler,TX
Vehicle: 2000 Ford Ranger XLT 4X2
Posts: 407
Total Props: 0
You can get a uv dye kit at auto zone for $30-$40 jut put it in the ac system like your filling it with freon and then use the glasses to see if you have any leaks
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone here had any issues with wheel adapters? alljackedup Suspension Tech 5 07-17-2008 08:38 PM
Has anyone had problems with 4 wheel parts? fx2offroadranger General Ford Ranger Discussion 11 10-02-2007 03:15 PM
Anyone had body lift problems? Red_Ak_Ranger General Ford Ranger Discussion 19 05-16-2007 10:02 PM
Anyone had this problem? Wheel noise/vibration 03 Falcon Wing General Technical & Electrical 24 06-08-2006 09:29 AM
Has anyone had this happen? BrianD 2.9L & 3.0L V6 Tech 13 06-07-2006 01:13 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:36 PM.