Auto computer causing issues? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 10-27-2013
Thread Starter

I am: Matt Hodge
Join Date: Oct 2013
Location: Charleston, wv
Vehicle: 1989 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 1
Total Props: 0
Auto computer causing issues?

I have a 89 ranger, 2.3 5 speed, got the truck as a project. When I got it it had a miss and was idling high, checked everything plugs, wires, iac, tps, vacuum lines, etc. I pulled the Codes on it and it has MAP sensor and then 3-4 auto trans codes, I get to looking and the computer is from an auto, my question is could the computer be causing it because it's for an auto or not? Like to know before I start checking the timing belt and investigating further. Thanks ahead for any help.
Reply With Quote
+ 0 -
Old 11-15-2013
I am: Denay Kirby
Join Date: Nov 2013
Location: Lafayette
Vehicle: 1997 Mazda B2300
Drive Type: 4x2
Engine: 2.3
Posts: 3
Total Props: 0
I had this same problem on mine but mine is a 97 so not sure how much the computer controls on older models, but short answer is yes. I had rough idle and a cylinder misfire, replaced plugs and coil packs still nothing and it turned out it was the PCM. If its anything like mine though, the good news is that the computer is easy to get to and replace. Much easier than the timing belt.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
ECU reset causing head lamp issues Shy Guy General Technical & Electrical 0 10-02-2013 02:04 AM
For Sale: Misc Items: Auto + Computer - Cheap or Free! Rick-RF Miscellaneous Items 1 11-07-2011 10:44 PM
What could be causing this auto transmission problem? m00m0bile Drivetrain Tech 1 08-31-2009 10:23 AM
So what could be causing this CEL Code.. its a good one.. rngprerunner General Technical & Electrical 4 06-07-2006 04:06 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:20 AM.